Hosting dHosting.pl - 10% rabat! :-)

X3nO

Zapytanie wyświetla jeden rekord (?)

1 post w tym temacie

Witam, mam problem z zapytaniem SQL w IP.Board 3, mianowicie wyświetla mi tylko pierwszy rekord, jest ktoś w stanie naprowadzić mnie na błąd?

				$this->registry->DB('samp_db')->build( array(
					'select' => 'lastvisit, name, premium, premiumtime, skin, online',
					'from'  => 'Accounts',
					'where' => 'premium>=1',
					'order'=> 'premium desc'
				));
				$this->registry->DB('samp_db')->execute();

				while ($row = $this->registry->DB('samp_db')->fetch()) {
					$output .= '<tr class="row2">
						<td style="text-align: center;">'.$panel->formatSkin($row['skin']).'</td>
						<td style="text-align: center;">'.$panel->formatName($row['name'], '1').' ('.$panel->formatName($row['name'], '2').')</td>
						<td style="text-align: center;">';
						if ($row['online'] == 1) {
							$output .= '<span data-tooltip="Aktualnie przebywa na serwerze." class="ipsBadge ipsBadge_green">Aktywny</span>';
						} else {
							$output .= '<span class="ipsText_small desc">'.$this->registry->class_localization->getDate( $row['lastvisit'], 'LONG', 1, 1 ).'</span>';
						}
						$output .= '</td>
						<td style="text-align: center;"><span class="ipsText_small desc">'.$this->registry->class_localization->getDate( $row['premiumtime'], 'LONG', 1, 1 ).'</span></td>
					</tr>';
				}

 

Udostępnij tego posta


Odnośnik do posta
Udostępnij na stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Tylko zarejestrowani użytkownicy mogą dodawać komentarze

Dodaj konto

Załóż nowe konto. To bardzo proste!


Zarejestruj nowe konto

Zaloguj się

Posiadasz już konto? Zaloguj się tutaj.


Zaloguj się teraz

  • Przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników, przeglądających tę stronę.