Skocz do zawartości

Hosting dHosting.pl - 10% rabat!

SmQ

Logowanie przez Google - wyłączenie G+ api

Rekomendowane odpowiedzi

Hej,

dostałem maila, że 07.03 google wyłączy swoje G+ api i trzeba zmienić metodę logowania. Na stronie supportu IPB przeczytałem, ze najlepiej zmienić metodę logowania na Google Identity. Tak też zrobiłem, a G+ wyłączyłem. Jednak po paru chwilach widzę, że logowanie Googlem przestało mi działać i wyrzuca błąd.

g plus error.png

g plus2.png

gplus1.png

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Tak, chcę zaktualizować do 4.4, ale najpierw chcemy mieć pewność, że nic innego się nam nie rozsypie. Nie sądzę, aby w 4.3.6 ta metoda logowania została całkowicie porzucona. Wiem, że G+ zostanie wyłączone i porzucone, ale ja pytam o Cloud Identity, które włączyłem i które IMO powinno działać i na 4.3.6 i na 4.4.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Inaczej - Cloud Identity nie działa na 4.3.6 ale działa na pewno na obecnej wersji 4.4.1 - sprawdzone osobiście przeze mnie (zarówno na jednej jak i drugiej wersji). Z resztą spójrz na tytuł manuala logowania za pomocą Google w IPS - "Google (4.4 or above)"

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Czyli jak to? jak mam 4.3.6 i działa mi normalnie logowanie goglowskie to 7 marca przestanie?

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
11 minut temu, DejaVu24 napisał:

Czyli jak to? jak mam 4.3.6 i działa mi normalnie logowanie goglowskie to 7 marca przestanie?

Tak

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Napisano (edytowane)

Bez sensu, mam te api zrobione z tej strony, mam tam dodana swoją stronę

https://invisioncommunity.com/4guides/how-to-use-ips-community-suite/social-sign-in/google-44-or-above-r299/

Czyli jak zmienię na 4,4 to w PA są inne jakieś opcje do uzupełnienia, że to ma nie działać, bo wygląda jakby to to samo.

-edit

jeszcze lepiej, wchodzę na te goglowe api z tego linka wyżej, wywala że strona niezweryfikowana, próbuję sie zalogować na swojej stronie i wywala " Nie masz uprawnień, aby zarejestrować konto na tej stronie. " ..nie wiem o co chodzi, bo widzę że nowi normalnie się loguję przez gogla..

Edytowane przez DejaVu24

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Dobra, zaktualizowaliśmy na testowej domenie, to IPContente (Pages) sypie za to błędem.

 


SELECT core_follow.* FROM `orig_ipb_core_follow` AS `core_follow` WHERE follow_app='cms' AND follow_area='records1' AND follow_rel_id=653 LIMIT 0,25
IPS\Db\Exception: Total count attempted on a query not ran with SQL_CALC_FOUND_ROWS (-100)
#0 /home/audiostereo/www/new.audiostereo.pl/public_html/applications/cms/sources/Theme/Theme.php(610) : eval()'d code(1552): IPS\Db\_Select->count(true)
#1 /home/audiostereo/www/new.audiostereo.pl/public_html/applications/cms/modules/front/database/record.php(310): IPS\Theme\class_cms_database_display->record(Object(IPS\cms\Records1), '\n<div data-cont...', NULL, NULL)
#2 /home/audiostereo/www/new.audiostereo.pl/public_html/system/Dispatcher/Controller.php(96): IPS\cms\modules\front\database\_record->manage()
#3 /home/audiostereo/www/new.audiostereo.pl/public_html/system/Content/Controller.php(50): IPS\Dispatcher\_Controller->execute()
#4 /home/audiostereo/www/new.audiostereo.pl/public_html/applications/cms/sources/Databases/Dispatcher.php(347): IPS\Content\_Controller->execute()
#5 /home/audiostereo/www/new.audiostereo.pl/public_html/system/Theme/Theme.php(4309) : eval()'d code(16): IPS\cms\Databases\_Dispatcher->run()
#6 /home/audiostereo/www/new.audiostereo.pl/public_html/applications/cms/sources/Pages/Page.php(1242): IPS\Theme\content_pages_5()
#7 /home/audiostereo/www/new.audiostereo.pl/public_html/applications/cms/sources/Pages/Page.php(2217): IPS\cms\Pages\_Page->getHtmlContent()
#8 /home/audiostereo/www/new.audiostereo.pl/public_html/applications/cms/modules/front/pages/page.php(112): IPS\cms\Pages\_Page->output()
#9 /home/audiostereo/www/new.audiostereo.pl/public_html/applications/cms/modules/front/pages/page.php(43): IPS\cms\modules\front\pages\_page->view()
#10 /home/audiostereo/www/new.audiostereo.pl/public_html/system/Dispatcher/Controller.php(96): IPS\cms\modules\front\pages\_page->manage()
#11 /home/audiostereo/www/new.audiostereo.pl/public_html/applications/cms/modules/front/pages/page.php(33): IPS\Dispatcher\_Controller->execute()
#12 /home/audiostereo/www/new.audiostereo.pl/public_html/system/Dispatcher/Dispatcher.php(152): IPS\cms\modules\front\pages\_page->execute()
#13 /home/audiostereo/www/new.audiostereo.pl/public_html/index.php(13): IPS\_Dispatcher->run()
#14 {main}

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Zaktualizuj szablony do najnowszej wersji 4.4.

  • Lubię to 1

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Ok, mamy już rozwiązanie. W innym wątku naszemu programiście ktoś odpisał i wstało. Zaraz odpalę ten upgrade na produkcji, wcześniej tylko full backupy.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Dobra nasza testowa domena działa poprawnie, ale jak na produkcji chcemy zrobić update to wywaliło:

File Check

Some source files are not correct for the latest version. If you uploaded the files to your server manually, the process may have failed or not completed yet, or a new version may have been released since you downloaded. Download latest version from your client area and upload the files again in order to continue.


Go To Client Area 
 

If you are sure the files have been uploaded correctly, make sure the permissions are set correctly on them.

  • /home/www/prod.audiostereo.pl/www/applications/core/interface/task/task.php

Pliki od 4.4.1 są na serwerze. Mają uprawnienia 777

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

intermedia - profesjonalne rozwiązania Invision Power Board

---

Chcesz uzyskać szybko i sprawnie pomoc? Uzupełnij wersję i adres w profilu.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Tylko ja nie chcę upgradeować do bety. Wczoraj wyszedł stable 4.4.1.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Napisano (edytowane)

Przeszedł upgrade, ale wywaliło nam całe forum i wyświetla komunikat:

[[Template forums/front/topics/topic is throwing an error. This theme may be out of date. Run the support tool in the AdminCP to restore the default theme.]]

 

Na testowym nic takiego nie mieliśmy ;/

 

Edytowane przez SmQ

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Ok, już sobie poradziliśmy. Został jednak jeszcze błąd w IPContent (pages):


Error: Call to a member function url() on boolean (0)
#0 /home/www/prod.audiostereo.pl/www/applications/cms/modules/front/database/record.php(310): IPS\Theme\class_cms_database_display->record(Object(IPS\cms\Records1), '\n<div data-cont...', NULL, true)
#1 /home/www/prod.audiostereo.pl/www/system/Dispatcher/Controller.php(96): IPS\cms\modules\front\database\_record->manage()
#2 /home/www/prod.audiostereo.pl/www/system/Content/Controller.php(50): IPS\Dispatcher\_Controller->execute()
#3 /home/www/prod.audiostereo.pl/www/applications/cms/sources/Databases/Dispatcher.php(347): IPS\Content\_Controller->execute()
#4 /home/www/prod.audiostereo.pl/www/system/Theme/Theme.php(4309) : eval()'d code(17): IPS\cms\Databases\_Dispatcher->run()
#5 /home/www/prod.audiostereo.pl/www/applications/cms/sources/Pages/Page.php(1242): IPS\Theme\content_pages_5()
#6 /home/www/prod.audiostereo.pl/www/applications/cms/sources/Pages/Page.php(2217): IPS\cms\Pages\_Page->getHtmlContent()
#7 /home/www/prod.audiostereo.pl/www/applications/cms/modules/front/pages/page.php(112): IPS\cms\Pages\_Page->output()
#8 /home/www/prod.audiostereo.pl/www/applications/cms/modules/front/pages/page.php(43): IPS\cms\modules\front\pages\_page->view()
#9 /home/www/prod.audiostereo.pl/www/system/Dispatcher/Controller.php(96): IPS\cms\modules\front\pages\_page->manage()
#10 /home/www/prod.audiostereo.pl/www/applications/cms/modules/front/pages/page.php(33): IPS\Dispatcher\_Controller->execute()
#11 /home/www/prod.audiostereo.pl/www/system/Dispatcher/Dispatcher.php(152): IPS\cms\modules\front\pages\_page->execute()
#12 /home/www/prod.audiostereo.pl/www/index.php(13): IPS\_Dispatcher->run()
#13 {main}

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Dobra, udało się ogarnąć.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Ok, wygląda, że działa ten Google Identity nawet.


Za to po aktualizacji Chatbox przestał mi działać - nie da się dodać nowej odpowiedzi ;/

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Problem ROZWIĄZANY. Jeśli są jakiekolwiek wątpliwości, pytania proszę o założenie nowego tematu.

Wszelkie uzasadnione reklamacje/pretensje/sugestie/rady przyjmuje ekipa forum.

  • Lubię to 1

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Gość
Ten temat został zamknięty. Brak możliwości dodania odpowiedzi.

  • Ostatnio przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników przeglądających tę stronę.

×
×
  • Dodaj nową pozycję...

Powiadomienie o plikach cookie

Umieściliśmy na Twoim urządzeniu pliki cookie, aby pomóc Ci usprawnić przeglądanie strony. Możesz dostosować ustawienia plików cookie, w przeciwnym wypadku zakładamy, że wyrażasz na to zgodę.