Skocz do zawartości

Hosting dHosting.pl - 10% rabat!

Jurij

Dodawanie certyfikatu SSL do IPB 3.4.X

Rekomendowane odpowiedzi

Witajcie,

 

Podczas dodawania certyfikatu SSL do forum IPB 3.4 w zasadzie wszystko przebiegło pomyślnie poza jednym szczegółem. Forum działa prawidłowo pod adresem:

 

https://forum.xx

 

oraz przekierowanie z www również działa:

 

https://www.forum.xx

 

jednak gdy wpiszę w przeglądarkę samo forum.xx to wyświetla się bez https. Gdzie to naprawić?

 

Pozdrawiam

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Bez www. Mogę do nich napisać... Conf_global.php zmieniłem, w acp przekierowania pozmieniałem, teraz kombinuję z .htaccess ale bez rezultatów :(

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Aha, czyli dobrze kombinowałem z .htaccess tylko nieumiejętnie. Napisałem do supportu dHosting i dobry człowiek szybko poprawił w .htaccess co trzeba. A co było nie tak?

 

No więc w .htaccess jak mamy

 

<IfModule mod_rewrite.c>

</IfModule>

i na samym dole było:

 

RewriteCond %{HTTPS} !=on
RewriteCond %{HTTPS_HOST} ^www.forum.xx$
RewriteRule ^(.*)$ https://forum.xx $1 [R=301,L]

i kombinowałem z usuwaniem tego www, potem wklejałem to co na IZE proponowaliście czyli:

 

RewriteCond %{HTTPS} !=on
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}[L,R]

ale to nie zdawało egzaminu. Administrator dHosting zatem wyłączył to co nie działa:

 

#RewriteCond %{HTTPS} !=on
#RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}[L,R]

 

a na samą górę jeszcze przed kodem

 

<IfModule mod_rewrite.c>

 

dodał swoje dzieło:

 

RewriteEngine On
RewriteCond %{HTTPS} !^on$
RewriteRule ^(.*)$ https://www.forum.xx/$1 [R=301,L]

I teraz wszystko śmiga :) Także polecam dHosting, świetny support i SSL w pakiecie 😃

 

Pozdrawiam,

 

Jurij

  • Lubię to 1

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Pan Damian :) A co, źle coś zrobił? :P

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

No ja nie narzekam. Dodam tylko, że zgłoszenie napisałem o 19:22 a o 19:27 dostałem odpowiedź, że .htaccess został poprawiony i problem rozwiązany. Czyli support rozwiązał sprawę w mniej niż 5 minut, to naprawdę imponujące ;)

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Gość
Ten temat został zamknięty. Brak możliwości dodania odpowiedzi.

  • Ostatnio przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników przeglądających tę stronę.

×
×
  • Dodaj nową pozycję...

Powiadomienie o plikach cookie

Umieściliśmy na Twoim urządzeniu pliki cookie, aby pomóc Ci usprawnić przeglądanie strony. Możesz dostosować ustawienia plików cookie, w przeciwnym wypadku zakładamy, że wyrażasz na to zgodę.