Jump to content

Hosting dHosting.pl - 10% rabat!

SmQ

Problem z instalacją aplikacji

Recommended Posts

Po zmianie kontenera na serwerze mamy problem z instalacją aplikacji.

 

Za każdym razem pojawia się błąd:

1C133/9 Nie można zainstalować dodanej aplikacji, ponieważ nie jest to prawidłowa aplikacja lub archiwum jest uszkodzone.

Archiwum jest na pewno dobre, bo sprawdzaliśmy na kilku różnych aplikacjach.

 

Uprawnienia na katalog applications zmieniliśmy na 777 i nadal to samo.

Edited by SmQ

Share this post


Link to post
Share on other sites

Skoro coś pozmienialiście na serwerze to proszę pytać admina serwera. :) Skrypt forum sam w sobie działa dobrze skoro napisaliście, że archiwum (jak mniemam .tar) macie OK.

Przenoszę do innego działu.


intermedia - profesjonalne rozwiązania Invision Power Board

---

Chcesz uzyskać szybko i sprawnie pomoc? Uzupełnij wersję i adres w profilu.

Share this post


Link to post
Share on other sites

Na serwerze zrobiliśmy nowy kontener LXC. Zaczęło się od tych problemów z wolnym dodawaniem postów. Chcieliśmy więc wrzucić elasticsearch, bo tak nam radzono. Jednak mieliśmy na starym kontenerze jakieś Ubuntu 12 czy coś w tym stylu (niekompatybilne). Nasz admin postawił więc nowy kontener, tam najnowszego linuxa i elastica. Przekopiował na ten kontener wszelkie pliki i katalogi z wcześniejszego i przepiął.

 

Teoretycznie więc wszystkie uprawnienia na katalogach powinny się przenieść.

Share this post


Link to post
Share on other sites
30 minut temu, DawPi napisał:

archiwum (jak mniemam .tar) macie OK.

Archwium na pewno dobre, bo nawet dla testu pobieram tapatalka z ich strony i jest to samo.

Czy jakieś jeszcze katalogi powinny mieć 775 lub 777 na serwerze? Ustawiliśmy uploads i aplications, ale dalej wygląda, jakby gdzieś brakowało.

Share this post


Link to post
Share on other sites

Może jeszcze datastore/.

Po tych zmianach ścieżki się nie pozmieniały? Sprawdź ustawienie o nazwie Ścieżka do katalogu. Nawet jak z tego nie korzystacie to dam rozpoznaje ścieżkę serwerową:

image.png

 

A potem czy się wszystko zgadza tutaj:

image.png

 

image.png


intermedia - profesjonalne rozwiązania Invision Power Board

---

Chcesz uzyskać szybko i sprawnie pomoc? Uzupełnij wersję i adres w profilu.

Share this post


Link to post
Share on other sites

Mamy reddis włączony więc nie ma w ogóle tego pola ścieżka do katalogu.

Share this post


Link to post
Share on other sites

Po zmianie systemu przechowywania na domyślny (nie reddis) nadal to samo.

Share this post


Link to post
Share on other sites

Nie pokazuje się ta opcja w ogóle? To nie chodzi o zmianę tylko podejrzenie czy ścieżka serwera jest OK.


intermedia - profesjonalne rozwiązania Invision Power Board

---

Chcesz uzyskać szybko i sprawnie pomoc? Uzupełnij wersję i adres w profilu.

Share this post


Link to post
Share on other sites

Ścieżka jest ok.

 

Extraction from phar "/tmp/phpr9xEu1.tar" failed: Cannot extract "Application.php" to "xxxx/applications/newsletters/Application.php", setting file permissions failed

 

- xxx wycięta ścieżka

 

takie coś jest w error logu. Jakiegoś phara może trzeba instalowac na servie?

Share this post


Link to post
Share on other sites
1 godzinę temu, SmQ napisał:

Jakiegoś phara może trzeba instalowac na servie?

image.png


intermedia - profesjonalne rozwiązania Invision Power Board

---

Chcesz uzyskać szybko i sprawnie pomoc? Uzupełnij wersję i adres w profilu.

Share this post


Link to post
Share on other sites

PHPa teraz mamy 7.3, to w sumie jedyna zmiana na maszynie wzgledem starego kontenera.

Share this post


Link to post
Share on other sites

chmod na applications/ 777 nadany?


intermedia - profesjonalne rozwiązania Invision Power Board

---

Chcesz uzyskać szybko i sprawnie pomoc? Uzupełnij wersję i adres w profilu.

Share this post


Link to post
Share on other sites

Tak, chmod na wszystko już 777 nadany nawet był dla pewności :)

Share this post


Link to post
Share on other sites

No a co admin serwera na to? Od strony forum wszystko sprawdzone. 


intermedia - profesjonalne rozwiązania Invision Power Board

---

Chcesz uzyskać szybko i sprawnie pomoc? Uzupełnij wersję i adres w profilu.

Share this post


Link to post
Share on other sites
4 godziny temu, SmQ napisał:

PHPa teraz mamy 7.3, to w sumie jedyna zmiana na maszynie wzgledem starego kontenera.

U nas parę rzeczy niechcianych działo się na PHP 7.3, po przelaczeniu na 7.2 ustało. Taką radę tu dostałem i jak zwykle była dobra. 

  • Like 1

Share this post


Link to post
Share on other sites

Tak też zrobimy. Jutro spróbujemy zrobić downgrade. Chociaż ciężko mi uwierzyć, że nikt nie używa PHPa 7.3 i tego skryptu.

Share this post


Link to post
Share on other sites

I jakie wieści? Reputacje nadal się pojawiają?


intermedia - profesjonalne rozwiązania Invision Power Board

---

Chcesz uzyskać szybko i sprawnie pomoc? Uzupełnij wersję i adres w profilu.

Share this post


Link to post
Share on other sites

To nie ten temat ;)

 

Tu o aplikacjach.

 

Zrobilismy downgrade do 7.2 phpa, niestety nadal nie mozna instalowac aplikacji. Skonczyly sie nam pomysly :/

  • Like 1

Share this post


Link to post
Share on other sites
12 godzin temu, SmQ napisał:

To nie ten temat ;)

 

Tu o aplikacjach.

Kręćka można dostać. 😁

 

12 godzin temu, SmQ napisał:

Zrobilismy downgrade do 7.2 phpa, niestety nadal nie mozna instalowac aplikacji. Skonczyly sie nam pomysly 😕

Ten sam błąd co wyżej?


intermedia - profesjonalne rozwiązania Invision Power Board

---

Chcesz uzyskać szybko i sprawnie pomoc? Uzupełnij wersję i adres w profilu.

Share this post


Link to post
Share on other sites

Tak, bez zmian. Co prawda obeszliśmy to, bo ręcznie sobie rozpakowujemy aplikację i wrzucamy pliki do katalogu, ale to tymczasowe rozwiązanie.

Share this post


Link to post
Share on other sites

No oczywiście.

A folder tmp/ serwera poprawnie skonfigurowany?


intermedia - profesjonalne rozwiązania Invision Power Board

---

Chcesz uzyskać szybko i sprawnie pomoc? Uzupełnij wersję i adres w profilu.

Share this post


Link to post
Share on other sites

Pluginy się wrzucają normalnie?


intermedia - profesjonalne rozwiązania Invision Power Board

---

Chcesz uzyskać szybko i sprawnie pomoc? Uzupełnij wersję i adres w profilu.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.