Jump to content

Znaleziono x wyników - wyszukiwarka


teez
 Share

Recommended Posts

Hej,

 

co jakiś czas wyszukiwarka zaskakuje mnie swoimi mechanizmami. Weźmy sobie takie proste wyszukiwanie w jakimś przykładowym dziale:

https://forum.invisionize.pl/search/?q=test&quick=1&type=forums_topic&nodes=215

 

image.thumb.png.ee152758be5643bc72268796c7552619.png

 

Znaleziono 57 wyników, 3 strony.

 

Klikam na drugą stronę - nagle 'znika' wyszukiwanie w dziale Invision Power Board 4 (widoczne na screenie wyżej) i zastaję informację, że Znaleziono 2843 wyników

 

Podejrzewam, że taki mechanizm miał mieć jakiś logiczny sens, ale nie mogę go dostrzec. Czy nie intuicyjniej byłoby gdyby przejście na 2 stronę pokazało mi wyniki z tego działu, który sobie wcześniej zaznaczyłem? 

 

image.thumb.png.ecd8fe31e9cab2bc5dd1a45687837496.png

 

Jakieś pomysły skąd takie zagmatwane rozwiązanie?

 

 

 

Edited by teez

Znajdziesz mnie na LinkedIn

Link to comment
Share on other sites

13 minut temu, teez napisał:

Weźmy sobie takie proste wyszukiwanie w jakimś przykładowym dziale

Co to za dział?

 

Trochę się zgubiłem czytając jak odtwarzasz ten błąd.

Link to comment
Share on other sites

Posted (edited)

image.thumb.png.113616f7bfb4a24a8330fee7a8ccff8f.png

 

Dokładne wyszukiwanie znajduje się pod linkiem, który wrzuciłem w pierwszym poście - https://forum.invisionize.pl/search/?q=test&quick=1&type=forums_topic&nodes=215

 

Ten link jest wystarczający do odtworzenia błędu. Po otworzeniu zobaczysz:

 

image.png.5362f0f4c66ca3a921b11e8463ead9f6.png

 

A jak klikniesz "2":

 

image.png.bbb31d36da97567e56158f46b9cfa4cc.png

 

dzieje się magia 

 

image.png

 

 

 

 

 

 

@aXen

 

Cytat

Trochę się zgubiłem czytając jak odtwarzasz ten błąd.

 

nie jestem pewny czy to na pewno błąd czy może celowy mechanizm. 

 

Edited by teez

Znajdziesz mnie na LinkedIn

Link to comment
Share on other sites

Tak, to jest błąd, ale widzę że występuje on tylko tutaj na ize oraz na jednym forum gdzie jest IPS 4.5.

Widzę że ize jest zaktualizowane do 4.6.2 więc @DawPi musi to sprawdzić osobiście.

Link to comment
Share on other sites

Na forum IPS'u błąd ten nie występuje, natomiast u mnie na Pecetowicz na wersji 4.5.4 wyniki pokazują najpierw zawyżoną wartość a na drugiej stronie o kilkaset wyników mniej. Być może to przez długo nieprzebudowany indeks wyszukiwania. 

Link to comment
Share on other sites

 

29 minut temu, SeNioR napisał:

Na forum IPS'u błąd ten nie występuje, natomiast u mnie na Pecetowicz na wersji 4.5.4 wyniki pokazują najpierw zawyżoną wartość a na drugiej stronie o kilkaset wyników mniej. Być może to przez długo nieprzebudowany indeks wyszukiwania. 

 

Nope, to nie to. Przynajmniej u mnie przebudowanie indeksów nie pomogło nic, a nic. W moim przypadku jest ciekawiej - pokazuje 257 wyników (3 strony), a jak się przechodzi na drugą stronę to.. jest pusto. 😛 Stad sprawdzenie jak to wygląda na IZE. 

  • Like 1

Znajdziesz mnie na LinkedIn

Link to comment
Share on other sites

  • 2 weeks later...
W dniu 22.06.2021 o 20:52, SeNioR napisał:

Na forum IPS'u błąd ten nie występuje,

 

Sprawdziłem przed wysłaniem Ticketa. Ten sam problem występuje na IPS.

 

https://invisioncommunity.com/search/?q=test&quick=1&type=forums_topic&nodes=180

 

image.png.150febca1e2169e43b1cfca586982010.png

 

po przejściu na 2 stronę

image.png.ed7207170fe30614f463db95861ca40e.png

 

 

Tak jakby parametr '&nodes=180'  gubił się w trakcie przechodzenia po stronach. Ale jak się go doda: https://invisioncommunity.com/search/?&q=test&type=forums_topic&page=2&search_and_or=or&sortby=relevancy&nodes=180 do linku to niestety wynik jest taki: 

 

image.png.6543d090ddf6daebadd1dfa4b425b08b.png

 

 

Dam znać jak dostanę jakąś odpowiedź ;) 

  • Like 3

Znajdziesz mnie na LinkedIn

Link to comment
Share on other sites

Im dalej w las tym ciekawiej. 'select * from' powoduje infinity loading 

 

image.thumb.png.6683201d7a75aec552c6c81c79d9a480.png

 

 

 

Ustawienie w wyszukiwanu przedziału czasu np. 02.03.2010 - 04.03.2010 wyświetla zawartość z 03.03.2010 (co jest ok), ale jak się 04.03.2010 zmieni na 03.03.2010 to tej zawartości z 03.03.2010 nie ma. Trochę nieintuicyjne.

 

Wyszukiwanie 'improv' znajduje tylko tematy w których jest dokładnie słowo 'improv', gdzie w tym samym momencie wyszukiwanie 'improve' znajduje wyniki z 'improvements'

 

Kolejna porcja uwag poleciała do IPB. Może macie też coś od siebie to chętnie się dowiem. Wyszukiwarka jest dość istotną funkcjonalnością na forum przy którym pracuję i trochę słabo jeżeli tak to ma wyglądać. :P Chyba bez zaprzęgnięcia elastica ciężko tutaj zbyt wiele oczekiwać. 

  • Like 2

Znajdziesz mnie na LinkedIn

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.