Skocz do zawartości

Hosting dHosting.pl - 10% rabat!

Mateusz_K

Użytkownik
  • Zawartość

    87
  • Rejestracja

  • Ostatnia wizyta

  • Wygrane w rankingu

    1

Ostatnia wygrana Mateusz_K w dniu 10 Lipiec

Użytkownicy przyznają Mateusz_K punkty reputacji!

Reputacja

2 Neutralna

O Mateusz_K

  • Urodziny 18.10.1994

Informacje o forum

  • Wersja
    IPS 4.3.x

Ostatnie wizyty

116 wyświetleń profilu
  1. Mateusz_K

    Własny hook nie działa

    Właśnie niedawno udało mi się rozwiązać problem. Poszperałem w ustawieniach tego pola w bazie danych w ACP i okazało się, że miało wyłączone uprawnienia do zapisu to pole
  2. Mateusz_K

    Własny hook nie działa

    Próbowałem - również nie działa.
  3. Mateusz_K

    Własny hook nie działa

    Też nie działa, w ogóle te pole nie jest przesyłane w danych metodą POST.
  4. Mateusz_K

    Własny hook nie działa

    Ok, mam xmla : <?xml version="1.0" encoding="UTF-8"?> -<plugin update_check="" website="" author="Mateusz" version_human="1.0.0" version_long="10000" name="Promote advertisement"> -<hooks> -<hook filename="promote_adv" class="\IPS\cms\Records" type="C"> -<![CDATA[//<?php /* To prevent PHP errors (extending class does not exist) revealing path */ if ( !defined( '\IPS\SUITE_UNIQUE_KEY' ) ) { exit; } class hook57 extends _HOOK_CLASS_ { /** * Process create/edit form * * @param array $values Values from form * @return void */ public function processForm( $values ) { try { $values['field_157'] = 1; parent::processForm( $values ); } catch ( \RuntimeException $e ) { if ( method_exists( get_parent_class(), __FUNCTION__ ) ) { return call_user_func_array( 'parent::' . __FUNCTION__, func_get_args() ); } else { throw $e; } } } } ]]> </hook> </hooks> <tasks/> <widgets/> <htmlFiles/> <cssFiles/> <jsFiles/> <resourcesFiles/> <lang/> <versions/> </plugin>
  5. Mateusz_K

    Własny hook nie działa

    A mógłbyś powiedzieć gdzie go znajdę? Jest to mój pierwszy hook i nie do końca ogarniam jeszcze wszystko.
  6. Mateusz_K

    Własny hook nie działa

    Poprawiłem trochę tego hooka, i var_dumpy działają, ale nie wlatuje wpis do bazy danych. Mój kod hooka : //<?php /* To prevent PHP errors (extending class does not exist) revealing path */ if ( !defined( '\IPS\SUITE_UNIQUE_KEY' ) ) { exit; } class hook57 extends _HOOK_CLASS_ { /** * Process create/edit form * * @param array $values Values from form * @return void */ public function processForm( $values ) { if(static::$customDatabaseId == 30) { $values['field_157'] = 1; } parent::processForm( $values ); } } A błąd dostaję : IPS \ Db \ Exception (1366) Incorrect integer value: '' for column 'field_157' at row 1
  7. Mateusz_K

    Własny hook nie działa

    Można zamknąć, poradziłem sobie z tym.
  8. Mateusz_K

    Własny hook nie działa

  9. Cześć, stworzyłem swojego hooka. Rozszerza on klasę \IPS\cms\Records . Hook ten ma za zadanie wpisywać pewną wartość do bazy jeżeli użytkownik należy do grupy klubowicza. Jednak gdy dodaję var_dump w metodzie, to nic mi się nie wyświetla. Dostaję natomiast błąd : IPS \ Db \ Exception (1366) Incorrect integer value: '' for column 'field_157' at row 1 Wiem, że nie dostaje tutaj wartości integer, ale nie mogę nawet zdebugować kodu. Oto mój kod hooka : //<?php /* To prevent PHP errors (extending class does not exist) revealing path */ if ( !defined( '\IPS\SUITE_UNIQUE_KEY' ) ) { exit; } class hook41 extends _HOOK_CLASS_ { /** * Process create/edit form * * @param array $values Values from form * @return void */ public function processForm( $values ) { var_dump($values); exit; parent::processForm( $values ); } } Czy ktoś wie może dlaczego nie wyświetla mi się var_dump ?ID bazy danych też jest prawidłowe
  10. Mateusz_K

    Wyświetlanie nazw reszty forum w pasku nawigacyjnym

    Wiem, że tak trzeba zrobić, ale nie mogę zrobić tego tak jak jest na obrazku. Jak dodaje menu rozwijane, to jest strzałka przy napisie Forum, a tego nie chcę. Edit: Już ogarnąłem jak to się dodaje
  11. Mateusz_K

    Wyświetlanie nazw reszty forum w pasku nawigacyjnym

    Czy takim sposobem jak na obrazku dam radę to zrobić ? Bo nie wiem w jaki sposób można tak podpinać te podkategorie do głównej kategorii
  12. Mateusz_K

    Wyświetlanie nazw reszty forum w pasku nawigacyjnym

    Faktycznie, dobry pomysł. Tylko jak wykryć, że kliknąłem w jakieś forum ? Bo dopiero wtedy chcę, żeby pojawiły się te nazwy w menu. A jeśli jestem na głównej stronie, to nie chcę aby były one wyświetlone.
  13. Cześć. Potrzebuję zrobić na forum coś takiego, że po wejściu w jakieś forum, będę miał w pasku nawigacyjnym wyświetlone resztę nazw dostępnych forum, aby można było dostać się na szybko do jakiegoś innego forum a nie trzeba by było się cofać do głównej strony, żeby wejść w jakieś inne forum. W jaki sposób można by było zrobić coś takiego ?
  14. Cześć, zmieniłem logowanie na HTTPS, wszystko działa oprócz logowania przez Google. Jeśli ssl jest wyłączony to logowanie przez Google działa, ale jak włącze SSL to po zalogowaniu przez Google wywala białą stronę z napisem, że strona nie działa i wywołuje zbyt wiele przekierowań. W czym może tkwić problem ? Wersja 3.3.4
  15. Mateusz_K

    htaccess przekierowania

    Niestety nie działa ten kod. Po dodaniu tego w htaccess, wywala mi błąd, że strona nie działa i dodatkowo dostaje info : "Strona spowodowała zbyt wiele przekierowań." I od razu kieruje mnie po https, nie mogę nawet wejść poprzez http.
×

Powiadomienie o plikach cookie

Umieściliśmy na Twoim urządzeniu pliki cookie, aby pomóc Ci usprawnić przeglądanie strony. Możesz dostosować ustawienia plików cookie, w przeciwnym wypadku zakładamy, że wyrażasz na to zgodę.