Jump to content

shigs1337

Member
  • Posts

    7
  • Joined

  • Last visited

Informacje o forum

  • Wersja
    IPS 4.5.x
  • Forum
    pif-paf.pl

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

shigs1337's Achievements

Newbie

Newbie (1/14)

4

Reputation

  1. Tak, diagnostyka pokazała właśnie tylko błąd z czasem i już hosting poprawił ten błąd. Wydaje mi się, że wszystko wróciło do normy. Trochę pospieszyłem się z tym tematem, ale strasznie zależało mi na poprawieniu wszystkiego, bo będę po prostu resztę dnia niedostępny. W takim wypadku można chyba zamknąć. O ile nie ma żadnych innych obowiązkowych rzeczy, które trzeba wykonać po przywróceniu backupu. Dzięki za odpowiedź
  2. Cześć.. Wczoraj (około 1 w nocy) bazy danych hostingu na którym stoi moje forum miały awarię i support przywrócił na stronie backup z godziny 01:00 03.02.2021. Poza utratą całego dnia pojawiło się kilka błędów. Przykładowo na chatboxie trzeba po wysłaniu wiadomości odświeżyć stronę, aby wpis był widoczny. Stąd moje pytanie.. Czy w którymś miejscu powinno się coś poprawić, aby forum funkcjonowało normalnie? Czy po przywróceniu takiego backupu trzeba zwrócić uwagę na coś szczególnego? Czy te rzeczy z odświeżaniem są nadal winą hostingu? W ACP mam błąd odnośnie aktualnego czasu, który może być nieaktualny. Próba naprawy nie przynosi skutku, zatem musi zająć się tym hosting? Czy mogę to poprawić sam w którymś miejscu w bazie danych?
  3. 0 błędów. Jedynie, że mam starszą wersję PHP (7.1.33). Wszystko działa poprawnie.
  4. Nie znalazłem jakiegoś konkretnego sposobu i robiłem wszystko ręcznie.. Eksportowałem każdą tabelę po kolei sprawdzając czy struktura się zgadza tj. czy wszystkie kolumny są takie same - jeśli były takie same to importowałem bazę z forum do tej czystej (usuwając po prostu całą tabelę na tym 'czystym' forum) i tak aż zrobiłem całość. Jeśli jakaś kolumna się nie zgadzała z czystą wersją to ją po prostu usuwałem. Niektóre kolumny przechowywały te same rekordy, ale miały inne nazwy, więc zmieniałem je ręcznie. Na końcu już całą bazę wyeksportowałem i zaimportowałem do forum na hostingu. Strasznie głupie, ale wolałem męczyć się z takim czymś niż stracić miesiąc działania - no i najważniejsze, że zadziałało.
  5. Zainstalowałem czystego IPS 4.4.2 na localhoscie, przeniosłem całą bazę łącząc ją z aktualnym forum (tj istniejące rekordy - userzy, tematy etc.) i po tym zabiegu wyskoczyła mi opcja aktualizacji do 4.5.3, która już przebiegła normalnie. Można zamknąć temat ;-)) Trochę było to czasochłonne, ale zadziałało!
  6. A jeśli załóżmy nie ma kopii zapasowej bazy danych? To znaczy ta hipotetycznie jest, ale przekładałem naprawę tego z dnia na dzień ciągle wrzucając backupy i ostatnia kopia bazy, która działała jest z 13 września.. Jest jakieś inne rozwiązanie? Właśnie jakoś wolałbym uniknąć cofnięcia się o miesiąc. A czy zainstalowanie czystego IPS 4.5.3, następnie połączenie baz danych dla wspólnych tabel - tj. import rekordów z bazy 4.4.2 do tabel, które istnieją w 4.5.3 dałoby coś? W sensie, czy takie coś ma w ogóle sens od strony technicznej? Ewentualnie przywrócenie struktury bazy danych z ips 4.4.2 z aktualnymi rekordami. Bo w sumie jeśli w bazie mam tabele, które są wyłącznie 4.5.3, a strukturę bazy miałbym pod 4.4.2 (wcześniej wrzucając pliki właśnie z tej wersji IPS) to czy te 'puste' tabele by przeszkadzały jeśli podszedłbym znowu do aktualizacji? Napisałem dość chaotycznie, ale raczej zrozumiale. Po prostu już zbyt długo z tym się męczę i mam dosyć..
  7. Hej, ostatnio aktualizowałem forum do 4.5.3, lecz po zaktualizowanie rozsypało mi się całe forum wraz ze stylem, więc postanowiłem wrzucić backup (co było chyba najgłupszym moim pomysłem..), aby forum wstało na nogi.. Aktualnie sytuacja wygląda tak, że forum posiada wersje 4.4.2, ale w ACP widnieje, że zainstalowana wersja to 4.5.3 (zapewne przez to, że wrzuciłem tylko backup plików bez bazy danych). Na forum nie pojawia się informacja o aktualizacji forum do 4.5.3, przez /admin/upgrade wyskakuje, że mam aktualną wersję. Zmieniłem w bazie danych wersje forum z 4.5.3 na 4.4.2 wtedy upgrade się odpalił, ale był problem z nieistniejącymi tabelami w bazie danych, bądź było ich zbyt dużo.. Czy jest jakaś opcja przebudowania bazy danych, aby nie sypała nieistniejącymi tabelami podczas aktualizacji? A może jest jakieś inne rozwiązanie tego bagna, w które sam wszedłem? Czy może muszę czekać do następnej aktualizacji IPS, żeby wszystko zadziałało poprawnie?
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.