Jump to content

SMTP/SendGrid/mailer dla wersji 3.4.X


 Share

Recommended Posts

Jest tak:

1. Wersja forum: wg. ACP 3.4.5 wg. mnie 3.4.9, do upgrade'u jeszcze trochę, myślę że minimum 3 miesiące, ze względu na konieczność przepisania kilku modów, aplikacji bez których forum nie ma sensu, skina - oryginalny jaki jest każdy widzi... itd... Ale o tym potem :)

2. Cloudflare

3. Uprzedzając, nie mogę użyć PHPMaila ani żadnego systemu, który wyśle w nagłówkach IP serwera, dopiero się pozbyłem DDoS-ów 😕

 

Przyszedł mi do głowy pomysł użycia SendGrid'a, bo:

1. w wersji obecnej 4.6.10, konfiguracja zajmuje kwadrans i śmiga jak złoto,

2. miałbym gotowca do nowej wersji.

 

Ale, o  ile konfiguracja w 4.6.10 zajmuje 15 minut, razem z rejestracją w SendGrid i konfiguracją Cloudflare (może tu jest jakiś haczyk?),

o tyle w 3.4.x - miszyn imposibul 😕

Albo oś poszło nie tak, albo ja coś źle robię, albo jest jakiś problem po stronie skryptu IPS-u. Raczej wykluczam problemy serwerowe, bo na tej samej maszynie mailer SendGrida, w wersji 4.6.10 lata jak wściekły :), czyli zakładam, że IPS dopisał obsługę SendGrida do nowej wersji, a to znaczyłoby, że można dopisać (jeśli to okaże się konieczne) do wersji 3.4.x. - na co jestem, jeśli nie będzie innego rozwiązania - ZDECYDOWANY.

 

Tzn. nie upieram się na SendGrida - potrzebuję mailera, który nie będzie po świecie rozsyłał domeny serwera i adresu IP, z limitem ok. 10000 maili/mies. - głównie rejestracje. 

 

Zanim napisałem tego posta, przetestowałem kilka/naście systemów SMTP, aż doszedłem do wniosku, że to nie tu trzeba szukać.

I jeszcze jedna konkluzja, wszystkie poradniki, tutoriale w sieci na ten temat, napisane kilka lat temu są dzisiaj niewiele warte. Firmy pozmieniały politykę,wprowadziły antyspamowe obostrzenia i nie jest już tak różowo, jak kilka lat temu :(

Link to comment
Share on other sites

Pomyślałem sobie, wybacz laikowi, że skoro Sendgrid działa pod 4.6.10 to jakby ktoś, kto się zna, zajrzał do źródła w 4.6.10, po czym zajrzał do źródła w 3.4.x to szybko zorientuje się czego brak i co trzeba dopisać. I dopisałby to, a ja zrewanżuję się banknotami NBP :)

Link to comment
Share on other sites

Powtórzę:

Cytat

 

...nie upieram się na SendGrida - potrzebuję mailera, który nie będzie po świecie rozsyłał domeny serwera i adresu IP, z limitem ok. 10000 maili/mies. - głównie rejestracje.

 

 

i będzie działał z wersją 3.4.x

 

Być może jest prostsze rozwiązanie niż SendGrid, może SMTP, a ja go nie umiem skonfigurować, może osobny serwer i przekierowanie rekordów MX domeny, nie wiem :( Dlatego piszę tu, w nadziei znalezienia rozwiązania. Zdaje sobie sprawę, że wersja skryptu (3.4.x) nie ułatwia sprawy, ale nie jest to przecież awykonalne?

Ktoś musiał mieć taki problem, ale IPS wyciął z forum wszystko (albo prawie wszystko), co tyczyło się wersji poniżej 4.x.x i zostały tylko jakieś resztki na innych forach, martwe linki do "fabrycznego" forum. Chodzę po necie i szukam rozwiązania, bo nie jestem z tych, i kco przychodzą i "daj" ale tu poległem, dlatego przychodzę po prośbie.  Zdaje sobie sprawę, że czas (i wiedza) kosztują, więc jestem otwarty na negocjacje $$ :)

 

 

Edited by Pianocraft
Link to comment
Share on other sites

Dobra, daliśmy radę, przy pomocy naszego Roota, chodzi mailer forumowy po SMTP.

A tak przy okazji, jest kilka wersji ClassEmail.php, wydanych po zakończeniu linii 3.4.x, w tym tak "ponumerowana":

 * IP.Board vVERSION_NUMBER
 * Send email using php mail() or SMTP
 * Last Updated: $Date: 2015-07-03 15:50:06 +0100 (Fri, 03 Jul 2015) $

to wygrzebane z produkcyjnej wersji,

W paczce instalacyjnej była starsza wersja.

Anyway, case closed :)

 

 

Link to comment
Share on other sites

  • Manager
W dniu 28.02.2022 o 20:38, Pianocraft napisał:

W paczce instalacyjnej była starsza wersja.

Ano nie, ja mam właśnie taką:

<?php

/**
 * <pre>
 * Invision Power Services
 * IP.Board v3.4.9
 * Send email using php mail() or SMTP
 * Last Updated: $Date: 2015-07-03 10:50:06 -0400 (Fri, 03 Jul 2015) $
 * </pre>

 

intermedia - profesjonalne rozwiązania Invision Power Board

---

Chcesz uzyskać szybko i sprawnie pomoc? Uzupełnij wersję i adres w profilu.

Link to comment
Share on other sites

Niby to samo, a nie takie samo :P

Już słabo pamiętam, ale IPS miał takich, nieudokumentowanych wersji, sporo. Nie wiem jak jest teraz, jeszcze nie do końca łapię się w wersji 4.6.x. - z tego co zdążyłem się rozejrzeć to przewrócili do góry nogami wszystko, ale to nie na ten post :)

Twoja wersja: IP.Board v3.4.9
Moja wersja:  IP.Board vVERSION_NUMBER
  • Like 1
Link to comment
Share on other sites

  • Manager

Problem ROZWIĄZANY. Jeśli są jakiekolwiek wątpliwości, pytania proszę o założenie nowego tematu.

Wszelkie uzasadnione reklamacje/pretensje/sugestie/rady przyjmuje ekipa forum.

intermedia - profesjonalne rozwiązania Invision Power Board

---

Chcesz uzyskać szybko i sprawnie pomoc? Uzupełnij wersję i adres w profilu.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.