Jump to content

Hosting dHosting.pl - 10% rabat!

Eurycide

Użytkownik
  • Content Count

    46
  • Joined

  • Last visited

Community Reputation

15 Neutralna

Informacje o forum

  • Wersja
    IP.Board 3.1.4
  1. Witam ponownie, to faktycznie błąd w skrypcie 3.0.4. Nie wiem dlaczego (i czy) nie występuje u wszystkich ale oto rozwiązanie: W pliku admin/sources/classes/itemmarking/class_itemmarking.php szukamy: /* We don't want to set empty arrays, so.. */ if ( is_array( $v ) AND ! count( $v ) ) { /* Do we have a cookie? */ $test = IPSCookie::get( $k ); if ( $test ) { /* set a blank, non sticky cookie */ IPSCookie::set( $k, '-', 0, -1 ); } else { continue; } } else if ( ! $v ) { IPSCookie::set( $k, $v, 1 ); } i zamieniamy na: IPSCookie::set( $k, $v, 1 ); To oficjalna poprawka - przynajmniej tymczasowa. Błąd ma zniknąć w 3.0.5.
  2. Mam to samo (upgrade 3.0.2->3.0.4). Dodatkowo przestał działać odnośnik "getnewpost" i zawsze przenosi do pierwszego posta w temacie...
  3. Ja się nie zgodzę Poprawia moim zdaniem czytelność. Wejdź do panelu / zarządzanie skinami / konkretny skin. Odszukaj szablon Widok forum / forumIndexTemplate znajdź: <!-- BEGIN TOPICS --> <if test="hastopics:|:is_array( $topic_data ) AND count( $topic_data )"> {parse striping="forumTable" classes="row1,row2"} <foreach loop="topics:$topic_data as $tid => $data"> dodaj poniżej: <!-- ROZDZIEL TEMATY PRZYKLEJONE --> <if test="$data['pinned']"> <if test="$this->hasPinned=1"></if> <else /> <if test="$this->hasPinned"> <if test="$this->hasPinned=0"></if> <tr class='subhead pinbar'> <if test="$this->memberData['is_mod'] == 1"> <th scope='col' colspan='6'> <else /> <th scope='col' colspan='5'> </if> </th> </tr> </if> </if> <!-- ROZDZIEL TEMATY PRZYKLEJONE --> Teraz otworz style - CSS / ipb_styles.css znajdź: .altbar { background: #376173; color: #fff; } dodaj poniżej: .pinbar { background: #ff0000; } Kolor możesz sobie zmienić, wstawić zamiast tego grafikę itd
  4. Dzięki za odpowiedź, a jest może publikowany spis modyfikacji wszystkich bitów, żeby ewentualnie niektóre poprawki IPSu nanieść sobie samemu? Widziałem, że do 3.0.2 była taka lista zmian w stylach. Widzę, że nie dajesz za wygraną. Najpierw muszę skończyć swojego skina
  5. Mam pytanie, które mnie nurtuje. Co się dzieje ze zmodyfikowanymi - własnymi skinami (modyfikacje CSS i templatów /szablonów) w przypadku aktualizacji powiedzmy 3.0.1 -> 3.0.3. Czy upgrader: - nadpisuje pliki szablonów i style (wracają do pierwotnej wersji) - modyfikuje szablony i style ale pozostawia zmienione czy dodane przez użytkownika elementy - nie wykonuje modyfikacji na skinach użytkownika? Chciałbym zrobić upgrade ale mam aktualnie autorskiego skina i sporo zmian zarówno w plikach stylów jak i w szablonach. Nie chciałbym sobie narobić niepotrzebnej roboty.
  6. Hm, nie wiem czy to wina cachowania sygnatur, ale po paru minutach od zmiany komuś sygnatury i po zaglądnięciu w jego profil, sygnatura pod postem nagle się "naprawia"
  7. Powyższe w moim przypadku nie było pomocne, ale rozwiązałem problem w inny i szybki sposób. Opiszę go, bo może komuś się przyda. Generalnie jeśli kodowanie na forum to ISO-8859-2 to tłumaczone na polski frazy będą posiadały "krzaki" jak np: ą ; zamiast "ą" itd. Krzaki te widać gdzieniegdzie na forum i w panelu admina pod "Wygląd / Manage Languages / Polski -> w paczkach językowych". Rozwiązanie: 1. Logujemy się do phpmyadmin'a 2. Robimy backup tabeli ibf_core_sys_lang_words (w skrócie: klikamy na tabelę, wybieramy EXPORT, SQL, bez struktury, zaznaczamy Dane (pełne i rozszerzone dodania) i Zapisz jako plik - klikamy wykonaj.) 3. Wykonujemy kolejno poniższe zapytania SQL (w skrócie: klikamy w zakładkę SQL i wklejamy zapytanie w pole tekstowe - klikamy wykonaj). Zapytania są w pliku tekstowym poniżej. sql.txt 4. W panelu admina w zakładce Wygląd / Manage Languages z listy rozwijanej wybieramy "Przebuduj wszystkie". 5. Gotowe Generalnie korzystamy z zapytania: UPDATE ibf_core_sys_lang_words SET word_custom = REPLACE(word_custom,"ciag_znakow_do_zamiany","nowy_ciag_znakow") wcześniej upewniamy się z jakiego typu błędami czy krzakami w kodowaniu mamy do czynienia.
  8. Dokładnie tak, jeśli zedytują samodzielnie, to problemu nie ma.
  9. Tak, jest pełna lista. Zresztą, kiedy edytuję własną sygnaturę to wszystko jest ok, ale przy edycji sygnatury innego użytkownika tekst się nie formatuje. Nie wiem czy to może mieć związek, ale nie mam także formatowania bbcode w wynikach wyszukiwania (tam gdzie znajduje się skrót posta)...
  10. Niestety po aktualizacji problem nadal występuje.
  11. No to pięknie. Niech mi ktoś jeszcze powie czy bezboleśnie można aktualizować bez utraty własnych skinów?
  12. Ano mam Może to jakiś problem po stronie serwera? Tylko czemu w widoku profilu działa tak jak i działa kiedy edytuję własną sygnaturę
  13. A są ustawienia dla grup? Jest chyba tylko jedno globalne w Tools & Settings > System Settings > Members > User Profile > Allow BBCode in signatures?
  14. Sprawdziłem na ftp i wszystkie pliki są / w niezmienionych wersjach.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.