Skocz do zawartości

Hosting dHosting.pl - 10% rabat! :-)

WSPIERAJ forum :)

DawPi

(DP32) Forum Icons

Rekomendowane odpowiedzi

fajna rzecz, ale:

- pod przeglądarką IE 8 paskudnie wyglada - tekst nazw działów wchodzi na ikonki, pod IE 9 jest OK

- nie działa na subdziały (laduja sie tylko domyslne) - mimo, ze w panelu admina jest wszystko OK

Edytowane przez Onil

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

- pod przeglądarką IE 8 paskudnie wyglada - tekst nazw działów wchodzi na ikonki, pod IE 9 jest OK

Nie będę pisać kodu pod przeglądarki, które nie trzymają standardów.

- nie działa na subdziały (laduja sie tylko domyslne) - mimo, ze w panelu admina jest wszystko OK

Po prostu trzeba zainstalować moda zgodnie z instrukcją, to zacznie działać.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

- nie działa na subdziały (laduja sie tylko domyslne) - mimo, ze w panelu admina jest wszystko OK

Jeśli nie edytowałeś forumindexTemplate to się nie dziw...

  • Lubię to 1

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

mam problem z ta wersją (innych nie testowałem)

po wgrywaniu obrazku do forum wyświetla się poniższa zawartość:

Błąd systemu

Can't move file.

ustawiłem chmod 777 dla folderu uploads oraz uploads/forumsicons

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

A dla tmp/ z chmodem 777? Serwery home? Zdjęcia (załączniki) się wgrywają?

P.s. uploads/forumsicons - forum, bez s.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

tmp ma 777, Serwery no-1.pl , zdjęcie profilowe w PNG załadowało.

Nie wiem czy to ma jakiś związek, ale napisałem pierwszy temat, lecz nie mogłem go otworzyć. To jest powiązane czy nie? Jeśli nie, to co może być tego przyczyną?

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Ot tak to Ci nie powiem.. Sprawdź czy na localhoście Ci działa. Jak działa to wiesz, co masz robić. :)

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

na localhoście niby ładuje, a jednak nie wyświetla na stronie głównej (w aplikacji wyświetla)

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

odkryłem coś takiego, jeśli wyświetlam obok nazwy to działa, a jeśli ma zamienić ikonkę tą standardową to już nic z tego

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

To wtedy nie ładuje z błędem Can't move file.? Trochę to nielogiczne. :glare:

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

nie nie, dwa posty powyższe pisałem o localhoście, co do serwera to będę próbował reinstalacji IPB

czyli, na serwerze całkiem nie działa i wyświetla się informacja Can't move file.

a na localhoście ładuję pliki i wyświetla przy opcji 'Next to the forum name' czyli obok nazwy forum wyświetla, a przy ustawieniu opcji 'Replace the indicator icon', czyli podmianie ikonek ze stylu, nie wyświetla ich

chyba wszystko wyjaśniłem, teraz jakieś propozycję co zrobić na localhoście by działało tak by podmienić ikony typu jak na PHPBB2 by przemo, przykład http://www.cs-holy.xaa.pl/

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

już wszystko działa, reinstalacja i usunięcie twojej modyfikacji (wyświetlanie podobnych tematów) pomogło

  • Lubię to 1

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Mam pytanie odnośnie tej modyfikacji, czy jest w niej funkcja ustawienia dwóch ikon, jedna pokazywała by że są nowe tematy druga że ich nie ma?

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Tak to ma działać (w domyśle), ale na jednym pliku graficznym, nie na dwóch.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Tzn. jest jedna grafika, a potem operując specjalnym kodem przyciemniam ją (na chwilę) w momencie, jak na forum nie ma nowych wpisów. Dzięki temu pozbywamy się niepotrzebnych dwóch ikon, zastępując je jedną.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Nazwa pliku: (DP32) Forum Icons

Autor: DawPi

Data wysłania: 04 sie 2011

Kategoria: English Versions

Wspierana wersja IP.Board: 3.2.x+

With this modification you can set icon for every or only selected forums.

Features:

  • enable/disable mod,
  • two display mode: next to the forum name (without any file or skin edits) or instead of indicator icon (require skin edits - work fine with the ajaxed marking),
  • set allowed extensions,
  • set maximum file size,
  • set maximum dimensions for icons,
  • enable/disable icon per forum,
  • tool to convert old settings from old version.

Note: skin edits are optional (but require to work in one of display modes).

Pobierz plik

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

witam a co zrobic jak nie mam lini :

ipb.global.registerMarker( "forum_img_{$forum_data['id']}", "{$forum_data['img_new_post']}", markerURL + "&forumid={$forum_data['id']}" );

w pliku : boardIndexTemplate

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Musisz mieć. Możesz spróbować poszukać fragmentu tego kodu, by znaleźć cały.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Hej

Używałem dłuższy czas (DP32) Forum Icons i nie sprawiał problemów, aż do dzisiaj.

Przy dodawaniu ikony stworzyło mi PUSTE FORUM w kategorii MMORPG

Do tego pustego działu nie można wejść, ma podstawową ikonę, nie można go usunąć.

W acp -> forums nie ma takiego działu zaś w panelu forum icons jest

Gdy chcę usunąć ten dział z panelu Forum Icons (bo z działów sie nie da ) to wyskakuje:

bug1f.png

W dziale Forum Icons wygląda to tak:

bug2t.png

Na forum zaś tak:

bug3m.png

Jak się uporać z tym irytującym problemem? Próbowałem szukać tego działu w bazie, ale do niczego nie doszedłem.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Hmm.. No, ale jak mogłeś stworzyć puste forum w FI, jak tam by dodać ikonę należy wybrać istniejące forum? Możesz coś więcej napisać?

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się


  • Przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników, przeglądających tę stronę.

×