Jump to content

IP.Content przekierowanie


KieCan
 Share

Go to solution Solved by BitGit,

Recommended Posts

Witam, od kilku dni próbuje skonfigurować IP.Content aby pokazywało na głównej stronie: http://www.yoursite.com

Natomiast kiedy wpisuje przekierowuje mnie do http://www.yoursite.com/index.html i wyskakuje błąd:

Not Found

The requested URL /index.html was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

 

Naprawdę nie wiem gdzie popełniłem błąd, czytałem tyle poradników i jakoś żaden nie mógł mi pomóc.

Ani nie mogę znaleźć żadnego który mógłby mi w jakiś sposób pomóc, dlatego proszę Was o pomoc.

Link to comment
Share on other sites

Mam wgrany plik htacces.txt w głównym folderze public_html

 

I włączoną funkcję Redirect to new friendly URL format w ustawianiach SEO? /to odnośnie edycji Twojego posta/

 

Tego raczej nie mam, gdzie to włączyć? :D

Link to comment
Share on other sites

Mam wgrany plik htacces.txt w głównym folderze public_html

 

 

Zapytam na wszelki wypadek - plik htaccess ma formę:

.htaccess

dosłownie (bez rozszerzenia .txt)

Edited by 9xx
Link to comment
Share on other sites

 

Mam wgrany plik htacces.txt w głównym folderze public_html

 

 

Zapytam na wszelki wypadek - plik htaccess ma formę:

.htaccess

dosłownie (bez rozszerzenia .txt)

 

 

Mi się pobrał plik "htaccess" bez kropki

 

@Edit:

Dodałem kropkę i usunąłem rozszerzenie .txt i działa, prawie.

Tylko że działa teraz przy formacie http://www.yoursite.com/index.html

Kiedy wpiszesz: http://www.yoursite.com przekierowywuje Cię do http://www.yoursite.com/index.html

A forum jest pod adresem: http://www.yoursite.com/forum/index.php?/index

a chce żeby było tylko pod /index lub /forum

Edited by KieCan
  • Like 1
Link to comment
Share on other sites

Przyjacielu, więc wgrałeś bezwartościowy plik. Musisz zawartość pobranego pliku wkleić sobie do notatnika, wyłączyć wszelkie formatowania tekstu i zapisać do jako .htaccess i w tej formie wgrać na serwer.

 

Co do pyt.2 na pewno nie masz włączonych przujaznych linków FURL. bo w adresie pojawia się index.pxp

Najpierw wgraj sobie ten htaccess a potem poszukaj w ACP ustawieniach Search Engine Optimization i włącz na TAK. (pliku drugi raz już nie musisz wgrywać)

Edited by 9xx
  • Like 2
Link to comment
Share on other sites

Działa, masz coś jeszcze aby forum było tylko pod /index a nie pod /forum/index?

 

@Edit:

PS: Teraz nie działa /members/ ani żadna inna aplikacja oprócz IP.Content i głowne forum

Edited by KieCan
Link to comment
Share on other sites

Teraz nie działa /members/ ani żadna inna aplikacja oprócz IP.Content i głowne forum

 

Działa pod adresem: /forum/index.php?/members/

Ale na pasku nawigacji jest teraz ustawione to jako: /forum/members/ - które nie działa, pokazuje się:

Nie możemy tego znaleźć!

 

[#404]

Nie udało się odnaleźć strony, którą próbujesz wyświetlić. kliknij tutaj, aby powrócić do strony głównej

Edited by KieCan
Link to comment
Share on other sites

A włączyłeś sobie przyjazne linki w ustawianiach Search Engine Optimization? Jeśli tak to:

 

 

ACP po lewej stronie masz listę narzędzi: znajdź ustawienie pamięć podręczna i tam przebuduj pamięć podręczną FURL - zadziałaj

Edited by 9xx
Link to comment
Share on other sites

W ustawieniach Search Engine Optimization, Friendly URL Features mam takie ustawienia:

 

Redirect to new friendly URL format: Tak
URL type: Query String
Use .htaccess mod_rewrite: Tak

Edited by KieCan
Link to comment
Share on other sites

ACP po lewej stronie masz listę narzędzi: znajdź ustawienie pamięć podręczna i tam przebuduj pamięć podręczną FURL - zadziałaj

 

Przebudowałem i nadal nie działa

Link to comment
Share on other sites

Nie wiem co Ci poradzić.

Jeżeli plik htaccess jest prawidłowy, w panelu zaznaczyłeś przekierowania na przyjazne linki a na serwerze jest włączona obsługa mod_rewrite to musi zadziałać. 

  • Like 1
Link to comment
Share on other sites

Obsługa mod_rewrite jest włączona w ustawieniach "Zaawansowanych" aplikacji oraz w "Search Engine Optimization"

Niestety nadal kiedy chce zobaczyć użytkowników na forum lub wejść w inne aplikacje pokazuje mi się:

Nie możemy tego znaleźć!

 
[#404]
Nie udało się odnaleźć strony, którą próbujesz wyświetlić. Kliknij tutaj, aby powrócić do strony głównej

 
Plik htaccess jest, działa tylko strona główna oraz Forum, nie moge sprawdzić użytkowników ani wejść w jakikolwiek dział.
 
Aby działo to muszę wyłączyć opcje "Use .htaccess mod_rewrite" w ustawieniu "Search Engine Optimization"
Tylko że wtedy jest taki link: "/forum/index.php?/members/" a ja chciałbym bez "index.php?"
No ale jeżeli się nie da to trudno.
Link to comment
Share on other sites

  • Solution

No to ma kolosalne znaczenie. Ty masz domenę podpiętą pod public_html a instalację w innym katalogu. Nie miało szans to zagrać - dwie zupełnie inne ścieżki..

 

Od początku.

Jeżeli upierasz się przy zachowaniu takiej instalacji skryptu z użyciem folderu /forum (na marginesie uważam to za błąd) to musisz wgrać do głównego katalogu domeny (zgaduję, że public_html)  plik index.php, który znajdziesz w katalogu Tools w pobranej paczce IP.Content.

 

Plik ten musisz wpierw edytować, a konkretnie musisz zmienić ścieżkę: 

$path_to_ipb   = ‘./forums/’; 

na

$path_to_ipb   = ‘/public_html/’;

jeżeli oczywiście to jest główny katalog na twoim serwerze. Jeśli masz po drodze np. katalog home to ścieżka musi wyglądać tak '/home/public_html/'; - generalnie ma to być prawidłowa ścieżka do katalogu Twojej domeny. 

 

Teraz do katalogu forum wgraj sobie osobny plik htaccess, którego zawartość musisz pobrać z ustawień SEO w ACP, włącz mod_rewrite i powinieneś cieszyć się dziwnym FURL tj. przykładowo: domena.com/forum/members zamiast optymalnego tzn: domena.com/members ;)

  • Like 2
Link to comment
Share on other sites

Wszystko działa, 9xx pomógł mi na PM bo tutaj już nie chciałem nabijać postów.

Jedyną rzeczą którą trzeba pamiętać i to co ja zrobiłem źle to ściągnięty plik ".htaccess" wrzucić tam gdzie jest zainstalowane forum.

Czyli jeżeli masz (tak jest w moim przypadku) forum zainstalowane w katalogu "forum" to plik .htaccess wrzuć do tego katalogu nie do public_html ;)


Pozdrawiam i Dziękuje za pomoc!  ^_^

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.