Skocz do zawartości

Hosting dHosting.pl - 10% rabat! :-)

WSPIERAJ forum :)

mosznix

Bład 500, strona nie działa

Rekomendowane odpowiedzi

Witam,

zmagam sie z problemem niedziałającej strony od 2 dni. Usługodawca nie wiele mi pomógł, znaczy wcale.

 PHP Parse error:  syntax error, unexpected '.' in csgdansk.pl/private_html/system/Theme/SandboxedTemplate.php on line 57

Ostatni błąd z konsoli.

Zmieniałem php 5.6 i 7.0

Z góry dziękuje za pomoc.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

z tego co kojarzę to 500 to raczej błąd serwerowy lub coś tam w htaccess nie tak ale w Twoim komunikacie pisze że masz w okolicach w pliku SandboxedTemplate.php w okoliacach linii 57 jakiś błąd składniowy, modyfikowałeś ten plik ? Ewentualnie pobierz nową wersję IPS odnajdź ten plik i przekopiouj na serwer. 

  • Lubię to 1

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Co na to support IPS?

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Support: 

Hello,

Have you recently updated IPS4 or did your webhost downgrade your php version? That error means that you're not using php 5.6 which is the min. required version for the recent IPS release.

Regards,
Daniel Fatkic
Invision Power Services, Inc.

 

Dwa dni temu serwer VPS nagle padł, nie dzialalo nic. Przywrócili wszystko, ale cos nie gra z php. Mam ustawiony php 7 tak jak było i 500 wyskakuje nadal.

Support mi w sumie nic nie pomoze bo to wina serwera a za to usługodawca mowi, ze wszystko dobrze..

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Skorzystaj z opcji w ACP:

 

"System" > "Support" > "Sprawdzanie systemu". Tam Ci coś pokazuje na czerwono - wywala błędy? 

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Sprawa wygląda następująco.

Pomimo iż w panelu DC mam ustawione PHP na poziomie 7, to strona i tak go nie czyta.

Na vps wyrzuca mi wersje php 5.5,. Nie wiem co ja robię zle, po aktualizacji dalej jest 5.5..

Kamilo, nie da sie wejsc do panelu bo strona całkowicie nie działa.

 

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Masz kompletnego IPSa? Chodzi o to czy są wszystkie katalogi i pliki. Pobierz najnowszą wersję i obczaj czy jest wszystko OK. 

Podaj jeszcze zawartość pliku "SandboxedTemplate.php"

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Owszem mam wpisane. Lecz nadal nie widzi php 7. 

Support po prostu odpisal ze nie mam php min 5.6

 

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Masz apache czy ngnix?

Sprawdzałeś czy pliki z php 7 zostały?

Ustaw php 7 jako domyślne php.

Spróbuj odinstalować php i zainstalować na nowo.

Jaki masz system/dystrybucję?

Edytowane przez BeZiCoVeR
  • Lubię to 1

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Poradziłem sobie z php.

Przerzuciłem sie z apache na nginx, ale nie mam pojęcia jak zrobić przekierowanie na ssl na nginx.

Poradzi ktos?

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Na digitalocean jest mnóstwo poradników, w ogóle jest wszędzie mnóstwo poradników.

My tu prowadzimy support dotyczący IPS, a nie jak przebudować serwer VPS :P 

  • Lubię to 1

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Ja rozumiem, ale jak nie przekieruje to forum nie bedzie działac. Tak strzelam. Nie czyta cache.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Nie mam. Nie chodzi o to ze google boli. Wbijam już 5 przykład z przekierowania i nie dziala, zirytowało mnie troche.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Tak, dla testu wrocilem do apacha. 

Nie mam juz pomysłów dlaczego forum nie działa. Dalej bład 500 pomimo, ze jest php 7.

Zauwazylem w logach ze licka jest zarejestrowana na podkatalof /forum, zresetowalem, ale kurde nie spodziewalem sie ze acp mi nie działa i nie mam jak jest teraz zarejestrowac.

Potrzebuje jednak szybkiej pomocy, nawet odpłatnie.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Rownie dobrze, mozesz zainstalowac nowe forum i tam dodac licencje, po czym je usunac i sprobowac na tamtym.

Mi za to pokazuje błąd 404.

 

Jeśli chcesz mogę pomóc bezpłatnie. Pisz na GG.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się


  • Przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników, przeglądających tę stronę.

×