Skocz do zawartości

Hosting dHosting.pl - 10% rabat!

WSPIERAJ forum :)

michal.rys.348

Przyjazne linki, htaccess, virtualbox, freebsd 11.2 i386

Rekomendowane odpowiedzi

Witam. Poprawiłem u siebie nginx na wirtualnej maszynie którą sam stworzyłem. Ustawiłem sobie przyjazne linki, .htaccess jest w prawidłowym katalogu, nadal go nie czyta i nie działają mi przyjazne linki.. Ktoś coś poradzi? 

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Gdzie je ustawiłeś i jaka zawartość jest w pliku .htaccess?

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Napisano (edytowane)
Godzinę temu, aXen napisał:

Gdzie je ustawiłeś i jaka zawartość jest w pliku .htaccess?

<IfModule mod_rewrite.c>
Options -MultiViews
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule \.(js|css|jpeg|jpg|gif|png|ico|map)(\?|$) /404error.php [L,NC]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

.htaccess 
/usr/local/www/nginx-dist/
Nawet mu nadałem 777 i nic..

 

Klikne np. w regulamin, pobiera mi się pliczek a taka zawartość w środku:

 

<?php
/**
 * @brief		Public bootstrap
 * @author		<a href='https://www.invisioncommunity.com'>Invision Power Services, Inc.</a>
 * @copyright	(c) Invision Power Services, Inc.
 * @license		https://www.invisioncommunity.com/legal/standards/
 * @package		Invision Community
 * @since		18 Feb 2013
 */
define('REPORT_EXCEPTIONS', TRUE);
$_SERVER['SCRIPT_FILENAME']	= __FILE__;
require_once 'init.php';
\IPS\Dispatcher\Front::i()->run();

Oprócz tego mam php 7.2.8 (php fpm)

Edytowane przez michal.rys.348

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
3 minuty temu, aXen napisał:

Ja mam włączone przepisywanie linków i przyjazne adresy. Lecz gdy włączę te przepisywanie to mi wywala taki komunikat:

Zdaje się, że przepisywanie adresów nie działa prawidłowo. Może to być spowodowane niewłaściwą konfiguracją serwera. 
Może to też być również fałszywy błąd, jeśli twoja strona nie jest ogólnie dostępna. Sprawdź czy działają przyjazne adresy URL. 
Upewnij się, że twój serwer jest poprawnie skonfigurowany lub skontaktuj się ze dostawcą hostingu lub administratorem serwera, w celu uzyskania pomocy.

 

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

No to skontaktuj się z administratorem serwera, być może nie masz włączonej funkcji mod _rewrite w PHP.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
2 minuty temu, aXen napisał:

No to skontaktuj się z administratorem serwera, być może nie masz włączonej funkcji mod _rewrite w PHP.

Ale ja FreeBSD sam zainstalowałem w programie virtualbox. Sam u siebie w domu hostuje na kompie. Ogólnie przy wejściu w acp mam komunikat:

Wyłącz niebezpiecznie funkcje PHP
Zaleca się wyłączenie następujących funkcji na twoim serwerze. Jeśli nie zarządzasz serwerem samodzielnie, twój dostawca hostingu powinien ci z tym pomóc. 

exec, system, popen, proc_open, shell_exec

 

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
3 godziny temu, aXen napisał:

No to skontaktuj się z administratorem serwera, być może nie masz włączonej funkcji mod _rewrite w PHP.

Orientujesz się jak ją zainstalować na freebsd 11.2 i386 pod najnowszego nginx z php fpm?

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
20 minut temu, Macsch15 napisał:

.htaccess jest pod Apache, Nginx ma inną składnie konfiguracji serwera httpd.

 

https://winginx.com/en/htaccess

Zmieniłem na .httpd

Kod skonwertowałem i jest :

# nginx configuration

location / {
  if (!-e $request_filename){
    rewrite \.(js|css|jpeg|jpg|gif|png|ico|map)(\?|$) /404error.php break;
  }
  if (!-e $request_filename){
    rewrite ^(.*)$ /index.php break;
  }
}

/usr/local/www/nginx-dist/ - mieści się tutaj.

Nadal ten sam problem 😕

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Konfigurację serwera NGINX znajdziesz (zależnie od systemu) w

/etc/nginx/sites-available/

Po zmianie musisz odpalić w konsoli SSH polecenie:

sudo service nginx restart

 

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Napisano (edytowane)

/usr/local/etc/nginx/nginx.conf

 

user  www;
worker_processes  1; #No. of processors
error_log /var/log/nginx/error.log info;

events {
    worker_connections  1024;
}

http {
    include       mime.types;
    default_type  application/octet-stream;

    access_log /var/log/nginx/access.log;

    sendfile        on;
    keepalive_timeout  65;
	
	client_max_body_size 30M;


    server {
        listen       80;
        server_name linoxide.com www.linoxide.com;
        root /usr/local/www/nginx;
        index index.php index.html index.htm;

	location / {
		try_files $uri $uri/ =404;
	#TUTAJ BYŁ PODPIĘTY

        error_page      500 502 503 504  /50x.html;
        location = /50x.html {
            root /usr/local/www/nginx-dist;
        }

        location ~ \.php$ {
                try_files $uri =404;
                fastcgi_split_path_info ^(.+\.php)(/.+)$;
                fastcgi_pass unix:/var/run/php-fpm.sock;
                fastcgi_index index.php;
                fastcgi_param SCRIPT_FILENAME $request_filename;
                include fastcgi_params;
        }
    }
}
}

Podpiąłem ten kod z ".httpd czy .htaccess" i nie działa nadal.

Edytowane przez michal.rys.348

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
13 minut temu, Macsch15 napisał:

To teraz sprawdź poprawność tego wszystkiego, co to za adres?


server_name linoxide.com www.linoxide.com;

 

Tutaj masz przykładową konfigurację: https://gist.github.com/danechitoaie/ccf16f5414443c0576db96531814653a

Stronka z tutorialu te linoxide.com ale to nic nie zmienia.. zmieniałem na swoje (hostuje u siebie na virtualboxie wiec domeny nie posiadam) tylko wpisalem same ip lokalne i jest to samo 

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Napisano (edytowane)
12 godzin temu, Macsch15 napisał:

Teraz mam ten sam problem ale na apache najnowszym. Mam .htaccess w:

/usr/local/www/apache24/data/ - tutaj jest forum i ten plik :) nawet temu .htaccess dałem 777 i nic dalej nie działa przepisywanie linków.

W lokalizacji:

/usr/local/etc/apache24/ jest plik o nazwie " httpd.conf" tutaj też dodałem regułkę:

<IfModule mod_rewrite.c>
Options -MultiViews
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule \.(js|css|jpeg|jpg|gif|png|ico|map)(\?|$) /404error.php [L,NC]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

Uprzednio usuwając ją z .htaccess.. 

Nawet ten plik httpd.conf przeniosłem do folderu z forum i nie działa.

Normalnie szału idzie dostać! opcję przyjaznych linków też mam zaznaczoną.

Chce wbić np. w kalendarz i 

Not Found
The requested URL /calendar/ was not found on this server.

A wszystkie pliki są na miejscu, nawet usuwałem i na nowo reinstalowałem forum. Pliki są z tej orginalnej paczki bo ja mam licencję. Ciągle się świeci:

 

Zdaje się, że przepisywanie adresów nie działa prawidłowo. Może to być spowodowane brakiem pliku .htaccess na serwerze. Może to też być również fałszywy błąd, jeśli twoja strona nie jest ogólnie dostępna. Sprawdź czy działają przyjazne adresy URL. Upewnij się, że poprawnie dodałeś na serwer plik .htaccess lub skontaktuj się ze wsparciem technicznym, w celu uzyskania pomocy.

Coś musi być z apache .. 

Oczywiście nginx był całkiem wyłączony jak włączyłem apache. Nawet zrobiłem osobną maszynę z samym apache bez nginx i jest to samo. I tym razem zainstalowałem php7.1 a nie 7.2.

Edytowane przez michal.rys.348

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Musisz znaleźć jakiegoś speca od serwerów który Cię tego nauczy no albo samemu drążyć. 

 

Ps z ciekawości - czemu się takimi rzeczami teraz zajmujesz? Co z forum?

  • Lubię to 1

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Napisano (edytowane)
5 minut temu, DawPi napisał:

Musisz znaleźć jakiegoś speca od serwerów który Cię tego nauczy no albo samemu drążyć. 

 

Ps z ciekawości - czemu się takimi rzeczami teraz zajmujesz? Co z forum?

No forum właśnie chce schostować sobie w domu na virtualnej maszynie bo za nim je zrobię to minie tego czasu cholera wie ile, a w domu będę miał za friko a za host trzeba płacić XD dopiero jak skończę to mam w planach od razu przenieść na host + domena albo vps ssd 

 

W sumie wiem gdzie może leżeć błąd. Na hime.pl nie działało mi 7.1 7.2 przy ipb.. działało 7.0 więc muszę poszukać jednego wpisu i jedną linię kodu wkleić i sprawdzę czy działa i dam znać.

Edytowane przez michal.rys.348

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się

  • Przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników przeglądających tę stronę.

×

Powiadomienie o plikach cookie

Umieściliśmy na Twoim urządzeniu pliki cookie, aby pomóc Ci usprawnić przeglądanie strony. Możesz dostosować ustawienia plików cookie, w przeciwnym wypadku zakładamy, że wyrażasz na to zgodę.