Jump to content

Hosting dHosting.pl - 10% rabat!

matma4u

Użytkownik
  • Content Count

    996
  • Joined

  • Last visited

Community Reputation

149 Dobra

Informacje o forum

  • Wersja
    IP.Board 3.4.8
  • Forum
    matma4u.pl

Recent Profile Visitors

12755 profile views
  1. Właśnie miałem taki sam problem. Tu opisałem moje rozwiązanie http://forum.invisionize.pl/topic/48155-migracja-na-nowy-serwer/
  2. Błąd był banalny, a przez to ciężki do zauważenia. Podczas importu nie wgrywała się cała baza jak należy. W pewnym momencie wyrzucało komunikat: Nie zwracałem na to uwagi. I to kosztowało mnie mnóstwo straconego czasu i nerwów. Tabele (np blog_entries) nie miały tworzone indeksów. Rozwiązanie problemu Szukamy w naszym pliku z kopią bazy danych zapytań tworzących indeksy tabel które w jednym zapytaniu SQL mają podwójny kod: ADD FULLTEXT KEY i dzielimy takie zapytanie na dwa odrębne np dla blog_entries mamy: -- -- Indexes for table `ipm_blog_entries` -- ALTER TABLE `ipm_blog_entries` ADD PRIMARY KEY (`entry_id`), ADD KEY `entry_blog_id` (`blog_id`,`entry_status`,`entry_date`), ADD KEY `entry_last_update` (`blog_id`,`entry_status`,`entry_last_update`), ADD KEY `entry_category_id` (`blog_id`), ADD KEY `entry_featured` (`entry_featured`), ADD KEY `entry_banish` (`entry_banish`), ADD KEY `entry_future_date` (`entry_future_date`,`entry_date`), ADD KEY `entry_rss_import` (`entry_rss_import`), ADD KEY `entry_date` (`entry_date`), ADD KEY `entry_status` (`entry_status`,`entry_last_update`), ADD FULLTEXT KEY `entry_name` (`entry_name`), ADD FULLTEXT KEY `entry` (`entry`); a powinno być: -- -- Indexes for table `ipm_blog_entries` -- ALTER TABLE `ipm_blog_entries` ADD PRIMARY KEY (`entry_id`), ADD KEY `entry_blog_id` (`blog_id`,`entry_status`,`entry_date`), ADD KEY `entry_last_update` (`blog_id`,`entry_status`,`entry_last_update`), ADD KEY `entry_category_id` (`blog_id`), ADD KEY `entry_featured` (`entry_featured`), ADD KEY `entry_banish` (`entry_banish`), ADD KEY `entry_future_date` (`entry_future_date`,`entry_date`), ADD KEY `entry_rss_import` (`entry_rss_import`), ADD KEY `entry_date` (`entry_date`), ADD KEY `entry_status` (`entry_status`,`entry_last_update`), ADD FULLTEXT KEY `entry_name` (`entry_name`); ALTER TABLE `ipm_blog_entries` ADD FULLTEXT KEY `entry` (`entry`); Zapisujemy plik i wgrywamy do bazy.
  3. Czyściłem tabele ipm_admin_login_logs ale to nic nie dało
  4. Date: Wed, 24 Feb 2016 22:49:22 +0000 Error: 1062 - Duplicate entry '0' for key 'PRIMARY' IP Address: 37.248.254.31 - /admin/index.php?adsess=&app=core&module=login&do=login-complete ---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------- mySQL query error: INSERT INTO ipm_admin_login_logs (`admin_ip_address`,`admin_username`,`admin_time`,`admin_success`,`admin_post_details`) VALUES('37.248.254.31','',1456354162,0,'a:1:{s:3:\"get\";a:4:{s:6:\"adsess\";s:0:\"\";s:3:\"app\";s:4:\"core\";s:6:\"module\";s:5:\"login\";s:2:\"do\";s:14:\"login-complete\";}}') .--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------. | File | Function | Line No. | |----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------| | admin/applications/core/modules_admin/login/manualResolver.php | [db_main_mysql].insert | 450 | '----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------' | admin/applications/core/modules_admin/login/manualResolver.php | [admin_core_login_manualResolver]._writeToLog | 168 | '----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------' | admin/applications/core/modules_admin/login/manualResolver.php | [admin_core_login_manualResolver].loginComplete | 105 | '----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------' | admin/sources/base/ipsController.php | [admin_core_login_manualResolver].doExecute | 306 | '----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------' ---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------- Date: Wed, 24 Feb 2016 22:49:40 +0000 Error: 1062 - Duplicate entry '0' for key 'PRIMARY' IP Address: 37.248.254.31 - /admin/index.php?adsess=&app=core&module=login&do=login-complete ---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------- mySQL query error: INSERT INTO ipm_admin_login_logs (`admin_ip_address`,`admin_username`,`admin_time`,`admin_success`,`admin_post_details`) VALUES('37.248.254.31','',1456354180,0,'a:1:{s:3:\"get\";a:4:{s:6:\"adsess\";s:0:\"\";s:3:\"app\";s:4:\"core\";s:6:\"module\";s:5:\"login\";s:2:\"do\";s:14:\"login-complete\";}}') .--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------. | File | Function | Line No. | |----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------| | admin/applications/core/modules_admin/login/manualResolver.php | [db_main_mysql].insert | 450 | '----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------' | admin/applications/core/modules_admin/login/manualResolver.php | [admin_core_login_manualResolver]._writeToLog | 168 | '----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------' | admin/applications/core/modules_admin/login/manualResolver.php | [admin_core_login_manualResolver].loginComplete | 105 | '----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------' | admin/sources/base/ipsController.php | [admin_core_login_manualResolver].doExecute | 306 | '----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'
  5. Dzień dobry, dziś przeniosłem forum na nowy serwer. Nie są to moje pierwsze przenosiny na inny serwer, jednak tym razem utknąłem na dobre. Już kilka razy wgrywałem pliki i bazę danych i ciągle to samo. Na stronie głównej brak formatowania: http://matma4u.pl Wszystko robiłem według tego: - https://www.invisionpower.com/support/guides/_/maintenance-and-server-configurations/transferring-community-to-a-new-server-r20 - https://www.invisionpower.com/support/guides/_/install-and-getting-started/installing-r18 Po wpisaniu odpowiednich ścieżek itd nie mogę logować się do ACP bo wyrzuca błąd połączenia z bazą, a na stronie głównej brak formatowania. Brak mi pomysłów co dalej robić. Proszę o rady.
  6. Czyli ogólnie lipa. Co do wersji IPB 3.4.x to rozumiem, że php7 może nie działać. W przypadku IPB 4.x jestem zdziwiony, tym bardziej, że w czasie pisania skryptu były już dostępne wersje beta php7 i można było już pomyśleć i dostosować się do nowych zaleceń. Tym bardziej, że gra jest warta świeczki.
  7. Witam Was, od kilku godzin walczę z IPB próbując go zmusić do pracy z php7. Bezskutecznie. Ciągle wyskakują jakieś błędy np, że jakiś znacznik ma status : deprecated itp. Czy komuś z Was udało się uruchomić w takiej konfiguracji IPB? A jeśli tak to czy warto, czy widać ten reklamowany podwójny przyrost wydajności php w stosunku do poprzedniej wersji?
  8. Problem rozwiązany. Zapomniałem aktywować w Apache wykonywanie plików .htaccess. Teraz wszystko działa jak należy
  9. Zobacz sam. Login: demo Hasło: demo http://matematyk.org/ Strona kodowana jest w UTF8. Główna wygląda ok, ale przy próbie wejścia do jakiegoś forum pojawia się błąd z kodowaniem. Nie rozumiem tego bo np. Nową zawartość wyświetla poprawnie czy też Tematy bez odpowiedzi., Panel użytkownika, Powiadomienia, Skrzynka odbiorcza Napisałem testową wiadomość na PW o treści: óŁłźćąę i w bazie zakodowana jest dobrze, widać óŁłźćąę Czemu tylko dla modułu rewrite działa źle?
  10. W bazie: Równania i nierówności, procenty, Na forum: Równania i nierównoÅ›ci procenty To tak wygląda jakby serwer kodował znaki w Latin-1
  11. Niestety nie zadziałało. Dalej krzaki.
  12. Dzień dobry, z myślą o migracji nan nowy serwer VPS postanowiłem dobrze przygotować się i przeprowadzić parę testów odnośnie wydajności i poprawności działania mojego projektu (http://matma4u.pl) Moje środowisko testowe to: - system Debian 8 - Apache 2.4.10 - PHP 5.6.9 - MySQL MariaDB 10.0 Poprzenosiłam pliki, nadałem odpowiednie uprawnienia i ruszyłem z testami. Wszystko, no prawie wszystko dobrze działa prócz bazy danych. - zamiast polskich znaków mam na stronie dziwne krzaczki. Baza oparta jest o silnik InnoDB. Po wgraniu je na serwer testowy przejrzałem kilka rekordów, czy wszystkie polskie znaki wyświetla poprawnie. W bazie wygląda to ok. Kodowanie bazy - UTF-8 Metoda porównywania znaków - utf8_general_ci Nie mam pomysłu czemu tak jest. Postanowiłem dokładnie porównać bazę live z bazą testową, ale są identyczne. Zapytania odnośnie struktury w obu bazach zwracają te same wyniki SHOW VARIABLES LIKE 'collation%'collation_connection utf8mb4_general_ci collation_database utf8_general_ci collation_server utf8_general_ci SHOW GLOBAL VARIABLES LIKE 'collation%'collation_connection utf8_general_ci collation_database utf8_general_ci collation_server utf8_general_ci SHOW VARIABLES LIKE 'character_set%';character_set_client utf8mb4 character_set_connection utf8mb4 character_set_database utf8 character_set_filesystem binary character_set_results utf8mb4 character_set_server utf8 character_set_system utf8 character_sets_dir /usr/share/mysql/charsets/ SHOW GLOBAL VARIABLES LIKE 'character_set%'character_set_client utf8 character_set_connection utf8 character_set_database utf8 character_set_filesystem binary character_set_results utf8 character_set_server utf8 character_set_system utf8 character_sets_dir /usr/share/mysql/charsets/ Na serwerze produkcyjnym działa wszystko ok, na testowy już nie. Gdzie tkwi błąd? W pliku konfiguracyjnym /etc/mysql/conf.d/mariadb.cnf mam ustawione poprawne wpisy: # MariaDB-specific config file. # Read by /etc/mysql/my.cnf [client] # Default is Latin1, if you need UTF-8 set this (also in server section) default-character-set = utf8 [mysqld] # # * Character sets # # Default is Latin1, if you need UTF-8 set all this (also in client section) # character-set-server = utf8 collation-server = utf8_general_ci character_set_server = utf8 collation_server = utf8_general_ci Kodowanie strony również jest w UTF-8. Pewnie gdzieś jest drobny błąd, ale gdzie? Proszę o pomoc w jego lokalizacji.
  13. Mam jeszcze kilka pomysłów, które czekają na realizacje np. instalacja modułu mod_pagespeed - https://developers.google.com/speed/pagespeed/module/?hl=pl, wyłączenie wszystkich niepotrzebnych modułów Apache itp To są tematy do następnych poradników.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.