Skocz do zawartości

Hosting dHosting.pl - 10% rabat!

Dementor

Przejście z HTTP na HTTPS

Rekomendowane odpowiedzi

Witam,

podpowiedzcie proszę gdzie ustawić url z https, na tą chwilę ustawiłem w .htaccess

Cytat

Options -MultiViews
RewriteEngine On
RewriteCond %{HTTPS} !on
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301,NC]
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule \.(jpeg|jpg|gif|png)$ /public/404.php [NC,L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !\..+$
RewriteRule . /index.php [L]

 

w conf_global.php

Cytat

$INFO['board_url']            =    'https://darksiders.pl';

 

 

Wiem, że w acp w ustawieniach też powinienem ale gdzie konkretnie? szukałem i mam tam z rozwijanych list tylko http.

 

Po zastosowaniu zmian w conf_global.php i .htaccess mialem komunikat

 

Cytat

Forbidden

You don't have permission to access / on this server.

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.


Apache/2 Server at darksiders.pl Port 443

 

Wróciłem więc do wcześniejszych ustawień w conf_global.php i .htaccess aby forum działało dopóki nie będę wiedział co i gdzie zmienić

 

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Takie pytanko - certyfikat SSL zakupiony i zainstalowany dla domeny?

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

To dziwne - w logach serwera coś tam jest? Niech admin sprawdzi.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Admin serwera odpisał:

 

"
W przypadku gdy na stronie występuje błąd 403, może to mieć związek z błędnymi uprawnieniami do pliku, który jest wywoływany lub katalogu dla niego nadrzędnego. Inną przyczyną mogą być infekcje na koncie, wówczas nasz system antywirusowy zmienia automatycznie rozszerzenie pliku na *.virus uniemożliwiając wykonywanie takiego pliku."

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

No, ale Ty zmieniasz http na https - więc może niech w tej materii rozpatrzy ten błąd?

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Odpowiedź od Admina:

 

Cytat

Proszę o zweryfikowanie uprawnień do plików i katalogów oraz sprawdzenie, czy w zarządzaniu domenami korzysta Pan z dowiązania symbolicznego private_html do public_html. Jeśli nie, to proszę o sprawdzenie, czy nie posiada Pan istotnych plików w /private_html, a następnie zapisanie dowiązania symbolicznego. Odpowiedź od Admina:

 

A jak Ty to robiłeś , tutaj macie https , co Ty zmieniłeś ? Ruszałeś .htaccess  i plik config?

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Czyli?

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Dokładnie powiązanie private_html do public_ html , jest to wymagane przy instalacji ssl dla domeny na serwerze.

 

Pomoże ktoś, kto ma http ?

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
5 minut temu, Dementor napisał:

Dokładnie powiązanie private_html do public_ html , jest to wymagane przy instalacji ssl dla domeny na serwerze.

 

Pomoże ktoś, kto ma http ?

sudo ln -s cieżka_do_źródła> cieżka_do_celu>

 

  • Nie lubię 1

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
23 godziny temu, pixelpuls napisał:

sudo ln -s cieżka_do_źródła> cieżka_do_celu>

 

Ja mam powiązanie symboliczne zrobione przez serwer nie przez htaccess.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Cytat

zrobione przez serwer nie przez htaccess.

Mógłbyś to rozwinąć? Przez serwer czyli jak?

  • Nie lubię 1

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Korzystałem z tego poradnika:

https://pomoc.biznes-host.pl/20,277,jak_dodac_certyfikat_ssl

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Htaccess uzupełniasz tak, jak w panelu miałeś zasugerowane.

 

Usuń domenę z Directadmina i potem na nowo stwórz z bezpiecznym SSL, przenieś pliki do private_html. Jak to zrobisz, załadowujesz oczywiście certyfikat - możesz użyć darmowego Let's Encrypt.

 

W configu zmieniasz na https://, potem wejdź w ACP i tam w konfiguracji ogólnej też zmień adres dla /uploads do https, potem tam poprawiasz ścieżkę do nowej (private_html).

  • Lubię to 2

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Niestety po wykonaniu tego co napisałeś efekt jest ten sam co wcześniej:

 

Cytat

Forbidden

You don't have permission to access / on this server.

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.


Apache/2 Server at darksiders.pl Port 443

 

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
W dniu 9.08.2018 o 12:34, PawelZerebiec napisał:

Może masz źle skonfigurowany certyfikat? Taka opcja tez moze byc...

A można to jakoś sprawdzić?

 

W dniu 12.07.2018 o 19:18, Dementor napisał:

Odpowiedź od Admina:

 

 

A jak Ty to robiłeś , tutaj macie https , co Ty zmieniłeś ? Ruszałeś .htaccess  i plik config?

 DawPi jak Ty to zrobiłeś?

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

No ja co - zmiana adresu w conf_global.php, włączenie pobierania grafik w ACP na FTP i przebudowa cache i działa. O to pytasz czy coś innego?

  • Dziękuję 1

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
W dniu 25.09.2018 o 12:13, DawPi napisał:

No ja co - zmiana adresu w conf_global.php, włączenie pobierania grafik w ACP na FTP i przebudowa cache i działa. O to pytasz czy coś innego?

Tak o to. Dzięki

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
W dniu 25.09.2018 o 12:13, DawPi napisał:

No ja co - zmiana adresu w conf_global.php, włączenie pobierania grafik w ACP na FTP i przebudowa cache i działa. O to pytasz czy coś innego?

przebudowa cache stylu ?

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Nie stylu, a forum. W zakładce Support -> Coś nie działa.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Mam wersję 3.2.3 i ona już nie ma wsparcia , Nie mam nic w system-> support,  jedyne co mam to przeliczanie i przebudowa, ale nie ma tam nic o cache.

  • Zmieszany 1

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Ok, znalazłem to

 

ACP > TOOLS & SETTINGS > Maintenance > Cache Control >> Update all caches

 

Zrobiłem tak jak Ty i działa. Do zamknięcia. Dzięki

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Gość
Ten temat został zamknięty. Brak możliwości dodania odpowiedzi.

  • Przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników przeglądających tę stronę.

×

Powiadomienie o plikach cookie

Umieściliśmy na Twoim urządzeniu pliki cookie, aby pomóc Ci usprawnić przeglądanie strony. Możesz dostosować ustawienia plików cookie, w przeciwnym wypadku zakładamy, że wyrażasz na to zgodę.