Jump to content

Hosting dHosting.pl - 10% rabat!

DawPi

IP.Board 3.4.8

Recommended Posts

OK, udalo sie z dodawaniem zalacznikow, wgranie paczki jezykowej dalo cos takiego

 There appears to be an error with the database.

If you are seeing this page, it means there was a problem communicating with our database. Sometimes this error is temporary and will go away when you refresh the page. Sometimes the error will need to be fixed by an administrator before the site will become accessible again.

You can try to refresh the page by clicking here 

Chyba cos zwalilem, mimo to paczka jest widoczna - ustawilem na domyslna, teraz nie ma zadnych napisow a najgorsze jest to ze skasowalem english, to tez nic nie dzalo....... ups

Share this post


Link to post
Share on other sites

Ok, udalo sie - wgralem plik na serwer, moze to prze moje slabe polaczenie wifi - dziekuje za pomoc.

Share this post


Link to post
Share on other sites

Whoops, to Ty facet jesteś. :o Adekwatny nick. :)

cache/ plik .cgi pokaż z dzisiejszą datą, bo wystąpił jakiś błąd z SQL.


intermedia - profesjonalne rozwiązania Invision Power Board

---

Chcesz uzyskać szybko i sprawnie pomoc? Uzupełnij wersję i adres w profilu.

Share this post


Link to post
Share on other sites
:) hehe jednak nie wszystko ok - sa braki, na przyciskach w widoku tematu nic sie nie wyswietla procz grafiki, w opcji dodawania zalacznika tez itp. Co zrobilem nie tak?

Share this post


Link to post
Share on other sites

Nie zainstalowałeś do końca języka. Napisałeś, że wystąpił błąd w bazie - no to poprosiłem o logi tego -> nie podałeś ich, więc poniekąd mam związane ręce.

Spróbuj zainstalować ponownie lang. Albo wrzuć pliki .php jako rozwiązanie tymczasowe, w jakimś temacie podawałem je w załączniku.


intermedia - profesjonalne rozwiązania Invision Power Board

---

Chcesz uzyskać szybko i sprawnie pomoc? Uzupełnij wersję i adres w profilu.

Share this post


Link to post
Share on other sites

Dodawalem ponownie ale jest to samo

===================================================
Date: Wed, 22 Jul 2009 12:19:51 +0000
Error Number: 1064
Error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1
IP Address: 86.202.160.99
Page: /admin/index.php?adsess=8ca775b7de0320eaf099a1681f882389&app=core&module=languages&section=manage_languages&do=language_do_import
Debug: array (
 1 => 
 array (
   'file' => '/ips_kernel/classDb.php',
   'line' => 988,
   'function' => 'query',
   'class' => 'db_driver_mysql',
 ),
 3 => 
 array (
   'file' => '/admin/applications/core/modules_admin/languages/manage_languages.php',
   'line' => 132,
   'function' => 'imprtFromXML',
   'class' => 'admin_core_languages_manage_languages',
 ),
 4 => 
 array (
   'file' => '/admin/sources/base/ipsController.php',
   'line' => 291,
   'function' => 'doExecute',
   'class' => 'admin_core_languages_manage_languages',
 ),
)
mySQL query error: SELECT word_app,word_pack,word_key,word_default FROM belcore_sys_lang_words WHERE lang_id=

Share this post


Link to post
Share on other sites
mySQL query error: SELECT word_app,word_pack,word_key,word_default FROM belcore_sys_lang_words WHERE lang_id=

Usunąłeś języki? :)

Znajdź ten post i wrzuć sobie pliki .php i sprawdź czy pomogło.


intermedia - profesjonalne rozwiązania Invision Power Board

---

Chcesz uzyskać szybko i sprawnie pomoc? Uzupełnij wersję i adres w profilu.

Share this post


Link to post
Share on other sites

ok znalazlem ale gdzie je ustawic? W cache/lang_cache ?

Nie wykasowalem? Zrobilem to po dodaniu polskiej paczki z panelu admina

Edited by michalinda

Share this post


Link to post
Share on other sites

cache/lang_cache/ i do każdego tam folderu wrzuć.


intermedia - profesjonalne rozwiązania Invision Power Board

---

Chcesz uzyskać szybko i sprawnie pomoc? Uzupełnij wersję i adres w profilu.

Share this post


Link to post
Share on other sites

powiedzmy ze wszystko jest ok, narazie :) Dzieki za pomoc i sorry za deszcz pytan - jestem totalnie swiezy w ipb, dopiero co kupilem licke, od 6 lat uzywalem phpbb2 ktore znam na wylot a 3 mnie zawiodla troche - sadzilem ze tutaj bedzie latwiej ale to pewnie kwestia przyzwyczajen ktore musze teraz zmienic - w kazdym badz razie dzieki.

Edited by michalinda

Share this post


Link to post
Share on other sites

Ważne!!!

Dla osób posiadających forum w kodowaniu innym niż UTF-8

Jeśli występują u Was błędy kodowania zawartości pliku ipb.lang.js macie dwie możliwości.

  • Panel administracyjny > Ustawienia systemowe > Performance > CPU Saving & Optimization > Reducing HTML output > Minify javascript? > oznacz na "Nie"
  • edytuj plik public/min/config.php i dodaj w nim poniższą linię
    $min_serveOptions['contentTypeCharset'] = 'iso-8859-2';


W końcu udało się przekonać IPS, że to jednak błąd i został on dziś naprawiony w wersji 3.0.2 :)

Share this post


Link to post
Share on other sites

W kwestii tłumaczenia trzy pytanka

1. po uploadzie pliku xml przez panel admina (bez jakichkolwiek błędów) - w widoku zarządzania językami, bardzo dużo pól "nowa wartość" jest pustych, pomimo tego, że na forum frazy z tych pól wyświetlają się poprawnie po Polsku.

2. W przypadku belki Nowej Zawartości, mam problem z przetłumaczeniem fraz zakładek "Forums, Members, Calendar" itd

3. Nie pomagają wyżej opisane kroki odnośnie pozbycia się krzaków po wgraniu polskiego języka (mam forum w kodowaniu ISO-8859-2). Pobrałem pliki tłumaczenia z ftp, przekonwertowałem na ISO-8859-2, nadpisałem pliki na FTP. Czy można w jakiś sposób zaktualizować wpisy w bazie na podstawie plików cache? Na forum nie ma żadnych zmian po tej operacji.

Dodam jeszcze, że aktualnie mam jeden język: Polski - pl_PL.ISO-8859-2

Edited by Eurycide

Share this post


Link to post
Share on other sites

Odniosę się po kolei:

ad 1 - ewidentnie nie poszło z importem. Spróbuj ponownie. Wszystkie pola muszą posiadać polskie odpowiedniki i posiadają.

ad 2 - spolszczenie jest zrobione w 100%. Jeśli w jakimkolwiek miejscu tak nie jest to znaczy, że nie zostało to umożliwione u twórców i należy to zgłosić - u nas na forum lub u nich ( IPS ).

ad 3 - krzaki -> jakie? Screen będzie wskazany. Aktualizacja bazy na podstawie plików - włączyć tryb developera i w zakładce Manage Languages pojawi się nowa opcja. :)


intermedia - profesjonalne rozwiązania Invision Power Board

---

Chcesz uzyskać szybko i sprawnie pomoc? Uzupełnij wersję i adres w profilu.

Share this post


Link to post
Share on other sites

Odniosę się po kolei:

ad 1 - ewidentnie nie poszło z importem. Spróbuj ponownie. Wszystkie pola muszą posiadać polskie odpowiedniki i posiadają.

ad 2 - spolszczenie jest zrobione w 100%. Jeśli w jakimkolwiek miejscu tak nie jest to znaczy, że nie zostało to umożliwione u twórców i należy to zgłosić - u nas na forum lub u nich ( IPS ).

ad 3 - krzaki -> jakie? Screen będzie wskazany. Aktualizacja bazy na podstawie plików - włączyć tryb developera i w zakładce Manage Languages pojawi się nowa opcja. :)

ad 1 - w jaki sposób najlepiej wykonać ponowny import, czy poprzez opcję Przebudowa z XML?

ad 2 - ok dziękuję za informację

ad 3 - w którym miejscu włącza się ten tryb?

Share this post


Link to post
Share on other sites

Ad 1 - próbować aż do skutku. :) Poważnie, sam to przerabiałem na localhoście.

Ad 2 - proszę.

Ad 3 - Enabling developer mode.


intermedia - profesjonalne rozwiązania Invision Power Board

---

Chcesz uzyskać szybko i sprawnie pomoc? Uzupełnij wersję i adres w profilu.

Share this post


Link to post
Share on other sites

 Zainstalowałem spolszczenie na forum (3.0.2 - może to jest przyczyną...). Posty, nazwy tematów i użytkowników, kategorie i ich opisy są ok. Jednak np. tutaj niektóre (bo "ó" się np. wyświetla) polskie literki wyświetlają się jako "?":

86611059.jpg

Kodowanie bazy danych jest w iso-8859-2.

Edited by Bartek

...

Share this post


Link to post
Share on other sites

Przeczytaj dokładnie pierwszy post.

Tak to jest jak styl Linearny nie jest domyślnym na forum...

Share this post


Link to post
Share on other sites

Zmieniłem w "Lokalizacja j?zyka" na pl_PL.ISO-8859-2 i dalej jest źle.


...

Share this post


Link to post
Share on other sites

Jak to wygląda w ACP w Wygląd > Manage Languages podczas edycji też są znaki zapytania?


intermedia - profesjonalne rozwiązania Invision Power Board

---

Chcesz uzyskać szybko i sprawnie pomoc? Uzupełnij wersję i adres w profilu.

Share this post


Link to post
Share on other sites

Jak to wygląda w ACP w Wygląd > Manage Languages podczas edycji też są znaki zapytania?

W ACP wszędzie zamiast polskich znaków są "?".


...

Share this post


Link to post
Share on other sites

No to wędruj do bazy danych i sprawdź jakie masz kodowanie tabel.


intermedia - profesjonalne rozwiązania Invision Power Board

---

Chcesz uzyskać szybko i sprawnie pomoc? Uzupełnij wersję i adres w profilu.

Share this post


Link to post
Share on other sites

Oczywiście, że .. nie. ;)

W widoku tabel bazy danych. Najlepiej pokaż screen.


intermedia - profesjonalne rozwiązania Invision Power Board

---

Chcesz uzyskać szybko i sprawnie pomoc? Uzupełnij wersję i adres w profilu.

Share this post


Link to post
Share on other sites

Czyli, że mam pokazać z screen z jakiejś tabeli? A proszę bardzo - pierwsza z brzegu:

catsjrg.jpg


...

Share this post


Link to post
Share on other sites

Nie, ze spisu tabel - tak napisałem wyraźnie wyżej.


intermedia - profesjonalne rozwiązania Invision Power Board

---

Chcesz uzyskać szybko i sprawnie pomoc? Uzupełnij wersję i adres w profilu.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.